Bug 1293060 - Unable to build libvirt on OpenBSD (undefined reference to xdr_uint64_t)
Unable to build libvirt on OpenBSD (undefined reference to xdr_uint64_t)
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Other
unspecified Severity low
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-19 13:42 EST by Jasper Lievisse Adriaanse
Modified: 2016-03-21 19:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-21 19:36:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unbreak build when xdr_uint64_t is not defined (1.56 KB, text/plain)
2015-12-19 13:42 EST, Jasper Lievisse Adriaanse
no flags Details

  None (edit)
Description Jasper Lievisse Adriaanse 2015-12-19 13:42:48 EST
Created attachment 1107788 [details]
Unbreak build when xdr_uint64_t is not defined

Since livirt 1.3.0 I'm no longer able to build libvirt on OpenBSD due to an undefined reference to xdr_uint64_t.
It seems this problem has been addressed in the past already so please find attached a patch which extends this approach. Note that I have only been able to test my modifications to the .c files as rpcgen failed to parse the .x files on OpenBSD (failed on 'hyper'):

/usr/bin/perl -w ./rpc/genprotocol.pl /usr/bin/rpcgen -h \
       logging/log_protocol.x ./logging/log_protocol.h
    unsigned hyper inode;

^^^^^^^^^^^^^^^^^^^^^^^^
logging/log_protocol.x, line 46: expected ';'
cannot shutdown /usr/bin/rpcgen:  at ./rpc/genprotocol.pl line 139.

It would be greatly appreciated if someone can verify that my patches build on Linux too. Note that it would probably unbreak the build on Cygwin too.
Comment 1 Cole Robinson 2016-03-21 19:36:25 EDT
It appears your patches went upstream, so closing

Note You need to log in before you can comment on or make changes to this bug.