This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1293068 - unable to choose "français (Canada)" from keyboard config tool
unable to choose "français (Canada)" from keyboard config tool
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: control-center (Show other bugs)
7.2
Unspecified Linux
unspecified Severity low
: rc
: ---
Assigned To: Rui Matos
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-19 15:38 EST by Daniel Villeneuve
Modified: 2016-11-03 19:00 EDT (History)
3 users (show)

See Also:
Fixed In Version: control-center-3.14.5-15.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:00:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot before selecting "français" (25.82 KB, image/png)
2016-01-24 13:49 EST, Daniel Villeneuve
no flags Details
screenshot after selecting "français" (46.52 KB, image/png)
2016-01-24 13:50 EST, Daniel Villeneuve
no flags Details
Screenshots from RHEL 7.2 Server x86_64 (110.93 KB, application/zip)
2016-06-20 05:49 EDT, Pavlin Georgiev
no flags Details
Screenshots from RHEL 7.3, nightly build 20160617. (170.80 KB, application/zip)
2016-06-20 05:50 EDT, Pavlin Georgiev
no flags Details

  None (edit)
Description Daniel Villeneuve 2015-12-19 15:38:09 EST
Description of problem:

In a Canada French setting, choosing the "français (Canada)" keyboard via the gnome keyboard application does not allow to select it:  the item is in the menu, but when selected, the "Ajouter" (Add) button on the top right of the window
is disabled.

However, the "Français (Canada)" keyboard is available (it took me a while to find that out, see case #01549756).

Version-Release number of selected component (if applicable):

3.14.5

How reproducible:


Steps to Reproduce:
1. Configure the environment as Canada French using Language/Country settings.
2. Try to select "français (Canada)" keyboard (with a lowercase "f").
3.

Actual results:

The "Ajouter" button is disabled, while the keyboard actually exists under
the name "Français (Canada)".

Expected results:

Either that the "français (Canada)" item be withdrawn from the options (so that we find "Français (Canada)" which is configured correctly) or bind the French Canadian keyboard to "français (Canada)".

Additional info:
Comment 2 Rui Matos 2016-01-04 10:50:52 EST
Can you provide a screenshot of these entries?

If I understand correctly, you're mistaking a list heading row "français (Canada)" (centered and unselectable) for the actual keyboard layout row "Français (Canada)" (left aligned and selectable) .
Comment 3 Daniel Villeneuve 2016-01-23 22:23:37 EST
Did you receive the screenshots I've sent?
Comment 4 Rui Matos 2016-01-24 08:08:22 EST
(In reply to Daniel Villeneuve from comment #3)
> Did you receive the screenshots I've sent?

No, please attach them here. There's a place for attachments just before the first comment on this bug report.
Comment 5 Daniel Villeneuve 2016-01-24 13:49 EST
Created attachment 1117655 [details]
screenshot before selecting "français"
Comment 6 Daniel Villeneuve 2016-01-24 13:50 EST
Created attachment 1117656 [details]
screenshot after selecting "français"
Comment 7 Daniel Villeneuve 2016-01-24 13:52:19 EST
I've uploaded two screenshots.  In the screenshot after selection, the only option is to cancel ("Annuler").
Comment 8 Rui Matos 2016-01-25 07:10:29 EST
(In reply to Daniel Villeneuve from comment #7)
> I've uploaded two screenshots.  In the screenshot after selection, the only
> option is to cancel ("Annuler").

After selecting what exactly?

On the after screenshot, the first row is just a heading that allows you to go back. The actual "Français (Canada)" keyboard layout row should be further down, you have to scroll to see it. Or you could use the filtering search box below.
Comment 9 Daniel Villeneuve 2016-01-25 21:57:00 EST
Looking at the "before" screenshot, this is the point where I got when wanting to add a french canadian keyboard.  At this point it seems I'm at the right place.

Then I click on the "français (Canada)" menu item and I get to the "after" screenshot, from which we see that no french keyboard is selected.

I know (now) that there is also a "Français (Canada)" menu item which works.

This bug report is about the "spurious" item spelled "français (Canada)" which leads to nothing (and could make you think that something is missing on the system).  Having found "français (Canada)" which does not work, I do not find it natural to continue searching for "Français (Canada)"...

So my suggestion about either getting rid of the vacuous entry "français (Canada)" or to bind it to the same behavior as "Français (Canada)".

The same problem might also be present for other entries in the menu.
Comment 11 Pavlin Georgiev 2016-06-20 05:48:52 EDT
TEST SETUP 1
Install RHEL 7.2 Server x86_64.
Choose option "Server with GUI"

TEST PROCEDURE 2
Log in to GNOME session.
Select Français (Canada) as language for the system.
Restart
Open control center -> Keyboad -> Add input source
The is no choice "Français (Canada)".
The bug appears.
Make screenshots.


TEST SETUP 2
Install RHEL 7.3 Workstation x86_64 nightly build 20160617.

TEST PROCEDURE 2
Log in to GNOME session.
Select Français (Canada) as language for the system.
Restart
Open control center -> Keyboad -> Add input source
Choose "Français (Canada)" as input.
It is there and working.
Make screenshots.


RESULTS
Upgrading control-center
    from: 3.14.5-8.el7
      to: 3.14.5-17.el7
has fixed the bug.
Comment 12 Pavlin Georgiev 2016-06-20 05:49 EDT
Created attachment 1169805 [details]
Screenshots from RHEL 7.2 Server x86_64
Comment 13 Pavlin Georgiev 2016-06-20 05:50 EDT
Created attachment 1169806 [details]
Screenshots from RHEL 7.3, nightly build 20160617.
Comment 16 errata-xmlrpc 2016-11-03 19:00:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2150.html

Note You need to log in before you can comment on or make changes to this bug.