This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1293087 - Deluge daemon does not stop correctly on system reboot or shutdown
Deluge daemon does not stop correctly on system reboot or shutdown
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: deluge (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Cronenworth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-19 20:41 EST by Remco
Modified: 2016-08-10 11:36 EDT (History)
4 users (show)

See Also:
Fixed In Version: deluge-1.3.13-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-10 11:36:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remco 2015-12-19 20:41:00 EST
Description of problem:

Whenever deluge-daemon is running and the system is restarted or shutdown, then the next time the system is up, all torrents will have lost their state and start downloading from 0% again. If you force a recheck on them, they will be found to be 100% completed. I believe this has something to do with shutdown/reboot because the problem does not occur when I manually stop deluge-daemon using systemctl before rebooting.

Version-Release number of selected component (if applicable):
Version: 1.3.12
Release: 1.fc23

How reproducible:
Happens on every system reboot or shutdown-boot if deluge-daemon was not stopped manually.

Steps to Reproduce:
1. Enable and start deluge-daemon.
1. Have a lot of completed torrents in Deluge.
2. Reboot system.
3. See all of your torrents start downloading from 0% again, until you force a recheck.

Actual results:
State is lost.

Expected results:
State is kept.

Additional info:
Comment 1 Michael Cronenworth 2015-12-20 11:51:52 EST
I cannot reproduce this.
Comment 2 Calum 2016-04-12 08:02:55 EDT
Depending on the number of torrents loaded it could be the timeout for service shutdown is not long enough to wait for a graceful shutdown of deluged. You can enable logging for the daemon and see what is actually happening when a shutdown request is received.

I have implemented a more robust code implementation for the 'corrupt state on crash' issue which will land in 1.3.13 and should (fingers crossed) finally prevent this.
Comment 3 Mr. Jester 2016-08-10 10:36:16 EDT
Further inspection, I have found the root cause and fix.  The deluge-web.service unit file has the wrong ExecStart value.  It should be set to 
ExecStart=/usr/bin/deluge-web -l /var/log/deluge-web.log -L warning

With this set, the /usr/bin/deluge binary is not required and you can remove the deluge-gtk dependency.
Comment 4 Mr. Jester 2016-08-10 10:48:20 EDT
Ignore my previous comment. Was added to the wrong bug.
Comment 5 Michael Cronenworth 2016-08-10 11:36:11 EDT
Deluge 1.3.13 has been released. This issue should be resolved.

Note You need to log in before you can comment on or make changes to this bug.