Bug 1293105 - mintMenuConfig.py doen't run and aborts with gtk errors
mintMenuConfig.py doen't run and aborts with gtk errors
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mintmenu (Show other bugs)
23
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-20 05:34 EST by Manni Heumann
Modified: 2016-01-29 01:00 EST (History)
1 user (show)

See Also:
Fixed In Version: mintmenu-5.6.5-2.fc23 mintmenu-5.6.5-2.fc22 mintmenu-5.6.5-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-21 21:22:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manni Heumann 2015-12-20 05:34:06 EST
Description of problem:

clicking on "Preferences" in mintmenu's context menu does nothing.

Trying from the shell:

# /usr/share/linuxmint/mintMenu/mintMenuConfig.py
/usr/lib64/python2.7/site-packages/gi/overrides/Gtk.py:50: RuntimeWarning: You have imported the Gtk 2.0 module.  Because Gtk 2.0 was not designed for use with introspection some of the interfaces and API will fail.  As such this is not supported by the pygobject development team and we encourage you to port your app to Gtk 3 or greater. PyGTK is the recomended python module to use with Gtk 2.0
  warnings.warn(warn_msg, RuntimeWarning)
Traceback (most recent call last):
  File "/usr/share/linuxmint/mintMenu/mintMenuConfig.py", line 536, in <module>
    window = mintMenuConfig()
  File "/usr/share/linuxmint/mintMenu/mintMenuConfig.py", line 293, in __init__
    self.getBackgroundColor()
  File "/usr/share/linuxmint/mintMenu/mintMenuConfig.py", line 380, in getBackgroundColor
    self.backgroundColor.get_color(color)
TypeError: Gtk.ColorButton.get_color() takes exactly 1 argument (2 given)


Version-Release number of selected component (if applicable):
5.6.5

How reproducible:
always

Steps to Reproduce:
see Description above

Actual results:
mintmenu configuration impossible

Expected results:
mintmenu configuration possible


Additional info:
Comment 1 Wolfgang Ulbrich 2015-12-22 15:36:34 EST
Hmm, i can't reproduce it here.
Can you please check if all runtime dependencies are installed?
python2
python-configobj
pygtk2
pyxdg
python-xlib
system-logos
pygtk2-libglade
yumex-dnf
beesu
mate-panel
mozo
xdg-utils
gobject-introspection
Comment 2 Manni Heumann 2015-12-23 03:49:03 EST
Checked. All those packages are installed and dnf reports "Nothing to do.".

By the way: deleting line 380 from mintMenuConfig.py makes the script run just fine.
Comment 3 Wolfgang Ulbrich 2016-01-04 09:10:25 EST
I forward the issue to upstream.
https://github.com/linuxmint/mintmenu/issues/148
Please write a comment there and you will get notifications if upstream have question.
Personal i don't have the issue and i don't want forward upstream questions to the report here.
Thank you
Comment 4 Fedora Update System 2016-01-13 20:13:24 EST
mintmenu-5.6.5-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8583c7c568
Comment 5 Fedora Update System 2016-01-13 20:13:29 EST
mintmenu-5.6.5-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-c9fc08d6dc
Comment 6 Fedora Update System 2016-01-14 05:24:28 EST
mintmenu-5.6.5-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-c9fc08d6dc
Comment 7 Fedora Update System 2016-01-14 06:24:30 EST
mintmenu-5.6.5-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-52506b977e
Comment 8 Fedora Update System 2016-01-15 14:53:01 EST
mintmenu-5.6.5-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8583c7c568
Comment 9 Fedora Update System 2016-01-21 21:22:04 EST
mintmenu-5.6.5-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2016-01-23 22:17:44 EST
mintmenu-5.6.5-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2016-01-29 01:00:43 EST
mintmenu-5.6.5-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.