Bug 1293106 - Cinnamon - Firefox search bar drop-down misplacement
Cinnamon - Firefox search bar drop-down misplacement
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-20 05:34 EST by Jonathan S
Modified: 2016-05-18 18:30 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-18 18:30:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of bug (1.27 MB, image/png)
2015-12-20 05:34 EST, Jonathan S
no flags Details

  None (edit)
Description Jonathan S 2015-12-20 05:34:33 EST
Created attachment 1107938 [details]
Screenshot of bug

Description of problem:


Version-Release number of selected component (if applicable):
Fedora 22/Cinnamon 2.6.13 and Fedora 23/Cinnamon 2.8.6 (& probably others)



Steps to Reproduce:
1. Open Firefox - click to show the drop-down list for the search bar

2. Move the Firefox window - click to show the drop-down list for the search bar
    Drop-down list appears in correct place

3. Again click to show the drop-down list for the search bar
    Drop-down list appears in the position relating to the original Firefox window placement


Additional info:

This appears to be a Cinnamon bug specific to the Fedora implementation.
The Fedora/Cinnamon versions shown above are on computers that also have other desktops installed (Gnome, Gnome Classic) and these other desktops do not show this bug.
Nor does the bug show under Mint (Mint 17.3, Cinnamon 2.8.6).
Nor does the Firefox version seem to matter - and the bug shows whether the search-bar is the old interface (one search provider per line) or the new (search providers as icon grid).

See attachment for example of bug. Note the tool-tip by the cursor and the corresponding highlighted icon on the misplaced grid.
Comment 1 leigh scott 2015-12-20 05:45:13 EST
fedora firefox uses gtk3 (mint uses gtk2)
Comment 2 Jonathan S 2015-12-20 11:15:26 EST
(In reply to leigh scott from comment #1)
> fedora firefox uses gtk3 (mint uses gtk2)

Hi Leigh

First of all, thanks for all your work on Fedora Cinnamon - I really appreciate it as it's my main OS/desktop.

I take your point about Fedora Firefox using gtk3. However, if it's a Firefox bug, why don't Gnome and Gnome Classic show these bugs? Both of my machines showing this bug have multiple desktops installed (Cinnamon, Gnome, Gnome Classic) and it's only Firefox under Cinnamon that shows the bug. Obviously, Firefox under these other desktops is using gtk3 - what gives?
Comment 3 Martin Stransky 2015-12-21 02:46:53 EST
That is:

https://bugzilla.redhat.com/show_bug.cgi?id=1281817
https://bugzilla.mozilla.org/show_bug.cgi?id=1022241#c26

There's a simple fix for that - ensure that Cinamon does not send configure notification signal to hidden windows (which is pointless anyway).
Comment 4 Martin Stransky 2015-12-21 02:49:20 EST
Moving back to cinnamon. If you don't want fix that on cinnamon side feel free to close/dupe it.
Comment 5 Jonathan S 2016-05-18 18:30:12 EDT
Cinnamon 3 has fixed this bug. :-)

Note You need to log in before you can comment on or make changes to this bug.