Bug 1293133 - all: fix clang compile warnings
all: fix clang compile warnings
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-20 08:59 EST by Kaleb KEITHLEY
Modified: 2016-06-16 09:51 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:51:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2015-12-20 08:59:22 EST
Description of problem:

compiling with clang (on Linux) reports many legitimate bugs not reported by gcc.


Version-Release number of selected component (if applicable):


How reproducible:

compile with clang


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

http://download.gluster.org/pub/gluster/glusterfs/static-analysis/master/glusterfs-clang/2015-12-18-9644769e/
Comment 1 Vijay Bellur 2015-12-20 11:11:15 EST
REVIEW: http://review.gluster.org/13031 (all: fixes for clang compile warnings) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Vijay Bellur 2015-12-22 17:20:08 EST
REVIEW: http://review.gluster.org/13031 (all: fixes for clang compile warnings) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 3 Vijay Bellur 2015-12-22 19:10:55 EST
REVIEW: http://review.gluster.org/13031 (all: fixes for clang compile warnings) posted (#4) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 4 Vijay Bellur 2015-12-23 09:54:38 EST
REVIEW: http://review.gluster.org/13031 (all: fixes for clang compile warnings) posted (#5) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 5 Vijay Bellur 2015-12-23 17:26:58 EST
REVIEW: http://review.gluster.org/13031 (all: fixes for clang compile warnings) posted (#6) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 6 Vijay Bellur 2016-01-05 14:25:32 EST
REVIEW: http://review.gluster.org/13031 (all: fixes for clang compile warnings) posted (#7) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 7 Vijay Bellur 2016-01-06 10:15:06 EST
REVIEW: http://review.gluster.org/13031 (all: fixes for clang compile warnings) posted (#8) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 8 Vijay Bellur 2016-01-06 12:27:19 EST
REVIEW: http://review.gluster.org/13031 (all: fixes for clang compile warnings) posted (#9) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 9 Vijay Bellur 2016-01-15 06:30:29 EST
REVIEW: http://review.gluster.org/13031 (all: fixes for clang compile warnings) posted (#10) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 10 Vijay Bellur 2016-02-15 04:36:23 EST
COMMIT: http://review.gluster.org/13031 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit d4c415776b20e4152d4a706276cb06d833a58baa
Author: Kaleb S KEITHLEY <kkeithle@redhat.com>
Date:   Sat Dec 19 20:27:17 2015 -0500

    all: fixes for clang compile warnings
    
    cli/src/cli-cmd-parser.c (chenk)
    cli/src/cli-xml-output.c (spandit)
    cli/src/cli.c (chenk)
    libglusterfs/src/common-utils.c (vmallika)
    libglusterfs/src/gfdb/gfdb_sqlite3.c (jfernand +1)
    rpc/rpc-transport/socket/src/socket.c (?)
    xlators/cluster/afr/src/afr-transaction.c (?)
    xlators/cluster/dht/src/dht-common.h (srangana +2)
    xlators/cluster/dht/src/dht-selfheal.c (srangana +2)
    xlators/debug/io-stats/src/io-stats.c (R. Wareing)
    xlators/features/barrier/src/barrier.c (vshastry)
    xlators/features/bit-rot/src/bitd/bit-rot-scrub.h (vshankar +1)
    xlators/features/shard/src/shard.c (kdhananj +1)
    xlators/mgmt/glusterd/src/glusterd-ganesha.c (skoduri)
    xlators/mgmt/glusterd/src/glusterd-handler.c (atinmu)
    xlators/mgmt/glusterd/src/glusterd-op-sm.h (atinmu)
    xlators/mgmt/glusterd/src/glusterd-snapshot.c (spandit)
    xlators/mgmt/glusterd/src/glusterd-syncop.c (atinmu)
    xlators/mgmt/glusterd/src/glusterd-volgen.c (atinmu)
    xlators/protocol/client/src/client-messages.h (mselvaga +1)
    xlators/storage/bd/src/bd-helper.c (M. Mohan Kumar)
    xlators/storage/bd/src/bd.c (M. Mohan Kumar)
    xlators/storage/posix/src/posix.c (nbalacha +1)
    
    Change-Id: I85934fbcaf485932136ef3acd206f6ebecde61dd
    BUG: 1293133
    Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/13031
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 11 Niels de Vos 2016-06-16 09:51:17 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.