Bug 1293135 - starting on 3.6 a vm snapshot taken with 3.5 fails
starting on 3.6 a vm snapshot taken with 3.5 fails
Status: CLOSED DUPLICATE of bug 1293299
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
3.6.1
Unspecified Unspecified
high Severity urgent (vote)
: ovirt-3.6.3
: ---
Assigned To: Arik
virt
:
Depends On:
Blocks: RHEV3.6Upgrade
  Show dependency treegraph
 
Reported: 2015-12-20 09:52 EST by Yedidyah Bar David
Modified: 2016-02-10 14:24 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-07 08:50:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
michal.skrivanek: ovirt‑3.6.z?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Yedidyah Bar David 2015-12-20 09:52:02 EST
Description of problem:

Starting of a vm from a previewed snapshot taken on 3.5 fails.

Version-Release number of selected component (if applicable):

3.6.1

How reproducible:

Always, on current setup

Steps to Reproduce:
1. Have a 3.5 engine, create a vm, take a snapshot of it with memory
2. Upgrade engine to 3.6
3. Try to preview the snapshot and start it

Actual results:

In web ui:

Error while executing action Run VM: Internal Engine Error

In engine.log:

execution failed: VDSGenericException: VDSErrorException: Failed to CreateVDS, error = Missing required parameter display, code = 11

in vdsm.log:

API::204::vds::(create) Missing required parameter display

Expected results:

Preview+start works

Additional info:
Comment 1 Yedidyah Bar David 2015-12-20 09:53:01 EST
vdsm was not upgraded, vdsm-4.16.27-1
Comment 3 Yaniv Kaul 2015-12-27 03:42:20 EST
Aharon, did your team reproduce this?
Comment 4 Aharon Canan 2015-12-27 04:07:46 EST
We didn't test upgrade, 
Maybe Nikolai will be able to answer this question better.
Comment 5 Michal Skrivanek 2016-01-04 05:56:55 EST
in general this needs to be blocked when everythin is upgraded to 3.6, see bug 1292398

but in this case of 3.5 cluster this should work just fine
Comment 6 Michal Skrivanek 2016-01-04 06:07:39 EST
engine.log is missing teh VM creation. Please attach correct log
Comment 7 Yedidyah Bar David 2016-01-04 06:18:22 EST
(In reply to Michal Skrivanek from comment #6)
> engine.log is missing teh VM creation. Please attach correct log

Sorry, attaching.
Comment 9 Nikolai Sednev 2016-01-05 04:38:14 EST
1)I've tried to perform the live snapshot with memory for the 3.6 VM running on our RHEV3 and failed, RHEV3 is running on  Red Hat Enterprise Virtualization Manager Version: 3.5.6.2-0.1.el6ev. 
2)Personally I did not tested this scenario, need to ask Kevin as snapshots are part of the storage sanity, we'll retest if not covered and provide more info later in this bug.
Comment 10 Yedidyah Bar David 2016-01-05 05:20:45 EST
Now tried restoring the snapshot without memory, and it still fails with same error. Attaching engine log.
Comment 12 Yedidyah Bar David 2016-01-05 05:27:07 EST
Guessing based on the error message, I tried editing the VM and change console type from spice to vnc. Tried both with and without restoring memory, both worked. Attaching log again.
Comment 14 Yedidyah Bar David 2016-01-05 05:52:50 EST
Did another test - restored with memory, edited console from spice to vnc, then edited again from vnc to spice, started - worked. Attaching logs.
Comment 16 Kevin Alon Goldblatt 2016-01-07 04:27:58 EST
(In reply to Nikolai Sednev from comment #9)
> 1)I've tried to perform the live snapshot with memory for the 3.6 VM running
> on our RHEV3 and failed, RHEV3 is running on  Red Hat Enterprise
> Virtualization Manager Version: 3.5.6.2-0.1.el6ev. 
> 2)Personally I did not tested this scenario, need to ask Kevin as snapshots
> are part of the storage sanity, we'll retest if not covered and provide more
> info later in this bug.

As discussed in my mail, I did not check this scenario. It is not part of the sanity test plan that we do. I can add it and test it in the next upgrade.
Comment 17 Arik 2016-01-07 08:50:46 EST
The end result of this bug is different than this of bz 1293299 - here the VM is not created while in bz 1293299 the VM is created but the user cannot connect to it with a console. The reason for that is probably the VDSM version - VDSM 4.16.27 fails to run VM when not specifying 'display' and newer VDSM versions manage to run it.

The addition of default graphics device when reading OVF is supposed to fix the problem of not setting 'display' when restoring a snapshot from a version lower than 3.6.

*** This bug has been marked as a duplicate of bug 1293299 ***

Note You need to log in before you can comment on or make changes to this bug.