Bug 1293162 - Latest update of wxPython seems to be broken
Latest update of wxPython seems to be broken
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: wxPython (Show other bugs)
epel7
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Scott Talbert
Fedora Extras Quality Assurance
:
: 1293432 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-20 15:52 EST by marcjero
Modified: 2016-01-07 14:27 EST (History)
8 users (show)

See Also:
Fixed In Version: wxPython-2.8.12.0-9.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-07 14:27:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description marcjero 2015-12-20 15:52:45 EST
Description of problem:

wxPython was ugraded to 2.8.12.0 today. Now when I start a Playonlinux program I get an error message. Playonlinux doesn't even start.


Version-Release number of selected component (if applicable):
2.8.12.0


How reproducible:
Install Playonlinux 4.2.9 and try to start a POL application.

Steps to Reproduce:
1. Install Playonlinux 4.2.9 (wxPython is a dependency)
2. Playonlinux fails to start

Actual results:
Error message
and POL application startup fails


Expected results:

Application should start as before

Additional info:

Error message 

Looking for python2... 2.7.5 - wxversion(s): 2.8-gtk2-unicode
Traceback (most recent call last):
  File "/usr/share/playonlinux/python/check_python.py", line 7, in <module>
    import wx
  File "/usr/lib64/python2.7/site-packages/wx-2.8-gtk2-unicode/wx/__init__.py", line 45, in <module>
    from wx._core import *
  File "/usr/lib64/python2.7/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 14813, in <module>
    from _gdi import *
  File "/usr/lib64/python2.7/site-packages/wx-2.8-gtk2-unicode/wx/_gdi.py", line 4, in <module>
    import _gdi_
ImportError: /usr/lib64/python2.7/site-packages/wx-2.8-gtk2-unicode/wx/_gdi_.so: symbol _ZN14wxGnomePrintDC13GetResolutionEv, version WXU_2.8 not defined in file libwx_gtk2u_core-2.8.so.0 with link time reference
failed tests
Please install python before trying to run this program
Comment 1 Tuomo Soini 2015-12-20 15:55:50 EST
It just needs rebuild becausue of rhel7.2 gtk2 update. I rebuild it locally and it fixed problems.
Comment 2 marcjero 2015-12-20 16:03:16 EST
Nice finding. Which RPM does need rebuild ?
Comment 3 Tuomo Soini 2015-12-20 18:02:50 EST
wxPython
Comment 4 Scott Talbert 2015-12-20 18:27:08 EST
Actually, it looks like this is due to wxGTK getting rebuilt to remove gnomeprint support.  Update is on the way.
Comment 5 Fedora Update System 2015-12-20 18:38:10 EST
wxPython-2.8.12.0-9.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-eeacd3b2e5
Comment 6 Yaakov Selkowitz 2015-12-21 13:37:56 EST
*** Bug 1293432 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2015-12-24 00:21:06 EST
wxPython-2.8.12.0-9.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-eeacd3b2e5
Comment 8 marcjero 2015-12-24 04:33:11 EST
wxPython-2.8.12.0-9.el7 fixed the issue for me
Comment 9 Marcelo Moreira de Mello 2015-12-30 17:00:57 EST
Worked to me too!
Comment 10 Fedora Update System 2016-01-07 14:27:52 EST
wxPython-2.8.12.0-9.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.