Bug 1293227 - Minor improvements and code cleanup for locks translator
Minor improvements and code cleanup for locks translator
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: locks (Show other bugs)
mainline
All All
low Severity low
: ---
: ---
Assigned To: Anoop C S
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 01:54 EST by Anoop C S
Modified: 2016-06-16 09:51 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:51:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anoop C S 2015-12-21 01:54:16 EST
Description of problem:

Use this bug to file changes that affect source files under xlators/features/locks directory. Real bugs (problem reports, crashes) should have their own bugzilla entry for related patches.

Acceptable changes include:
    -Improve code readability
    -Remove dead code
    -Better error reporting
    - . . .
Comment 1 Vijay Bellur 2015-12-21 01:57:22 EST
REVIEW: http://review.gluster.org/13033 (features/locks: Remove unneeded function parameter) posted (#1) for review on master by Anoop C S (anoopcs@redhat.com)
Comment 2 Vijay Bellur 2016-02-05 00:44:03 EST
REVIEW: http://review.gluster.org/13033 (features/locks: Remove unneeded function parameter) posted (#2) for review on master by Anoop C S (anoopcs@redhat.com)
Comment 3 Vijay Bellur 2016-03-22 15:38:07 EDT
COMMIT: http://review.gluster.org/13033 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 86501cd36b9784a6c0247326092a50fb44524656
Author: Anoop C S <anoopcs@redhat.com>
Date:   Sun Dec 20 21:47:37 2015 +0530

    features/locks: Remove unneeded function parameter
    
    We use list_del_init() inside __delete_lock()
    to remove a lock from inode's lock list where
    pl_inode_t is not required at all. This patch
    removes pl_inode_t from list of parameters
    required for __delete_lock().
    
    Change-Id: Ic5701bcae231172d4fd7feda1b25752343ee81cf
    BUG: 1293227
    Signed-off-by: Anoop C S <anoopcs@redhat.com>
    Reviewed-on: http://review.gluster.org/13033
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
Comment 4 Mike McCune 2016-03-28 18:22:31 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 5 Niels de Vos 2016-06-16 09:51:54 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.