Bug 1293245 - win10 guest crashed during boot (BSOD) with more than 36 usb sticks
win10 guest crashed during boot (BSOD) with more than 36 usb sticks
Status: CLOSED DUPLICATE of bug 1252134
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.8
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Gerd Hoffmann
hachen
:
Depends On:
Blocks: 1359965
  Show dependency treegraph
 
Reported: 2015-12-21 03:18 EST by jingzhao
Modified: 2017-02-06 04:23 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-06 04:23:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cli-5374 (5.19 KB, text/plain)
2015-12-21 03:18 EST, jingzhao
no flags Details
The screenshot for win10 didn't boot up (16.60 KB, image/png)
2015-12-21 03:21 EST, jingzhao
no flags Details
usb.sh (6.18 KB, text/plain)
2017-02-04 01:46 EST, hachen
no flags Details
test_usb.sh (5.56 KB, text/plain)
2017-02-05 23:34 EST, hachen
no flags Details

  None (edit)
Description jingzhao 2015-12-21 03:18:32 EST
Created attachment 1108225 [details]
cli-5374

Description of problem:
win10 guest didn't boot up when contain more than 36 usb sticks

Version-Release number of selected component (if applicable):
kernel version:2.6.32-592.el6.x86_64
qemu-kvm-0.12.1.2-2.481.el6.x86_64

How reproducible:
3/3

Steps to Reproduce:
1.create usb sticks with following cli:
#/bin/bash
for i in {a..i} 
do 
	for j in {a..z} 
	do 
		qemu-img create /home/usb-$i-$j.img 10M 
	done 
done

2. Boot guest with the script cli-5374

3. check usb through info usb
(qemu) info usb
  Device 0.1, Port 1, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.2, Port 2, Speed 12 Mb/s, Product QEMU USB Hub
  Device 0.3, Port 2.1, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.4, Port 2.2, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.5, Port 2.3, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.6, Port 2.4, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.7, Port 2.5, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.8, Port 2.6, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.9, Port 2.7, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.10, Port 2.8, Speed 12 Mb/s, Product QEMU USB Hub
  Device 0.11, Port 2.8.1, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.12, Port 2.8.2, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.13, Port 2.8.3, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.14, Port 2.8.4, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.15, Port 2.8.5, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.16, Port 2.8.6, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.17, Port 2.8.7, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.18, Port 2.8.8, Speed 12 Mb/s, Product QEMU USB Hub
  Device 0.19, Port 2.8.8.1, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.20, Port 2.8.8.2, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.21, Port 2.8.8.3, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.22, Port 2.8.8.4, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.23, Port 2.8.8.5, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.24, Port 2.8.8.6, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.25, Port 2.8.8.7, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.26, Port 2.8.8.8, Speed 12 Mb/s, Product QEMU USB Hub
  Device 0.27, Port 2.8.8.8.1, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.28, Port 2.8.8.8.2, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.29, Port 2.8.8.8.3, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.30, Port 2.8.8.8.4, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.31, Port 2.8.8.8.5, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.32, Port 2.8.8.8.6, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.33, Port 2.8.8.8.7, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.34, Port 2.8.8.8.8, Speed 12 Mb/s, Product QEMU USB Hub
  Device 0.35, Port 2.8.8.8.8.1, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.36, Port 2.8.8.8.8.2, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.37, Port 2.8.8.8.8.3, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.38, Port 2.8.8.8.8.4, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.39, Port 2.8.8.8.8.5, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.40, Port 2.8.8.8.8.6, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.41, Port 2.8.8.8.8.7, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.42, Port 2.8.8.8.8.8, Speed 12 Mb/s, Product QEMU USB MSD


Actual results:
Win10 guest didn't boot up

Expected results:
Win10 guest can boot up successfully

Additional info:
Comment 2 jingzhao 2015-12-21 03:21 EST
Created attachment 1108226 [details]
The screenshot for win10 didn't boot up
Comment 3 jingzhao 2015-12-21 03:22:28 EST
Rhel6 guest can boot up successfully with 37 usb sticks
Comment 12 hachen 2017-02-04 01:46 EST
Created attachment 1247640 [details]
usb.sh

kernel version: 2.6.32-682.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.501.el6.x86_64

I have tried 5 times with win10-64 using usb.sh and following the steps in commnet #0.

(qemu) info usb
  Device 0.1, Port 1, Speed 12 Mb/s, Product QEMU USB Tablet
  Device 0.1, Port 2, Speed 480 Mb/s, Product QEMU USB MSD
  Device 0.2, Port 3, Speed 480 Mb/s, Product QEMU USB MSD
  Device 0.3, Port 4, Speed 480 Mb/s, Product QEMU USB MSD
  Device 0.4, Port 5, Speed 480 Mb/s, Product QEMU USB MSD
  Device 0.1, Port 6, Speed 12 Mb/s, Product QEMU USB Hub
  Device 0.2, Port 6.1, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.3, Port 6.2, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.4, Port 6.3, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.5, Port 6.4, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.6, Port 6.5, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.7, Port 6.6, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.8, Port 6.7, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.9, Port 6.8, Speed 12 Mb/s, Product QEMU USB Hub
  Device 0.10, Port 6.8.1, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.11, Port 6.8.2, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.12, Port 6.8.3, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.13, Port 6.8.4, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.14, Port 6.8.5, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.15, Port 6.8.6, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.16, Port 6.8.7, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.17, Port 6.8.8, Speed 12 Mb/s, Product QEMU USB Hub
  Device 0.18, Port 6.8.8.1, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.19, Port 6.8.8.2, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.20, Port 6.8.8.3, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.21, Port 6.8.8.4, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.22, Port 6.8.8.5, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.23, Port 6.8.8.6, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.24, Port 6.8.8.7, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.25, Port 6.8.8.8, Speed 12 Mb/s, Product QEMU USB Hub
  Device 0.26, Port 6.8.8.8.1, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.27, Port 6.8.8.8.2, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.28, Port 6.8.8.8.3, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.29, Port 6.8.8.8.4, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.30, Port 6.8.8.8.5, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.31, Port 6.8.8.8.6, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.32, Port 6.8.8.8.7, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.33, Port 6.8.8.8.8, Speed 12 Mb/s, Product QEMU USB Hub
  Device 0.34, Port 6.8.8.8.8.1, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.35, Port 6.8.8.8.8.2, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.36, Port 6.8.8.8.8.3, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.37, Port 6.8.8.8.8.4, Speed 12 Mb/s, Product QEMU USB MSD
  Device 0.38, Port 6.8.8.8.8.5, Speed 12 Mb/s, Product QEMU USB MSD

Guest boots up as expected.
In win cmd type:
1. diskpart
2. list disk
All the usb storages are listed.
Comment 13 hachen 2017-02-04 04:00:44 EST
BUILD: qemu-kvm-rhev-0.12.1.2-2.481.el6 [469338] State: DELETED

kernel version: 2.6.32-592.el6.x86_64
qemu-kvm-0.12.1.2-2.479.el6.x86_64 and qemu-kvm-rhev-0.12.1.2-2.490.el6.x86_64

I have tried 5 times each with win10-64 using usb.sh and following the steps in commnet #0.


Guest boots up successfully in both cases.
Comment 14 hachen 2017-02-04 04:29:13 EST
Having tried 5 time each with win10-32 for both

kernel version: 2.6.32-682.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.501.el6.x86_64

and

kernel version: 2.6.32-592.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.490.el6.x86_64,

the guest can boot up successfully in both cases.
Comment 16 hachen 2017-02-05 23:34 EST
Created attachment 1247936 [details]
test_usb.sh

Having tried 5 time each with win10-64 and test_ues.sh for both

kernel version: 2.6.32-682.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.501.el6.x86_64

and

kernel version: 2.6.32-592.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.490.el6.x86_64,

the guest can boot up successfully in both cases.

The guest can not boot up might due to https://bugzilla.redhat.com/show_bug.cgi?id=1252134, as it didn't specify the cpu modle in the cli-5374.
Comment 17 CongLi 2017-02-06 01:52:15 EST
(In reply to hachen from comment #16)
> Created attachment 1247936 [details]
> test_usb.sh
> 
> Having tried 5 time each with win10-64 and test_ues.sh for both
> 
> kernel version: 2.6.32-682.el6.x86_64
> qemu-kvm-rhev-0.12.1.2-2.501.el6.x86_64
> 
> and
> 
> kernel version: 2.6.32-592.el6.x86_64
> qemu-kvm-rhev-0.12.1.2-2.490.el6.x86_64,
> 
> the guest can boot up successfully in both cases.
> 
> The guest can not boot up might due to
> https://bugzilla.redhat.com/show_bug.cgi?id=1252134, as it didn't specify
> the cpu modle in the cli-5374.

Based on the test results above, and have confirmed it with the reporter, it should be the problem of cpu model.

And it should be a dup to https://bugzilla.redhat.com/show_bug.cgi?id=1252134 which is same as comment 4.


Hi Gerd,

Could you please help check comment 16?

Is there any info we may missed?
If no, could we close this bug ?

Thanks.
Comment 18 Gerd Hoffmann 2017-02-06 04:18:52 EST
> Is there any info we may missed?
> If no, could we close this bug ?

Looks very plausible, can be closed as duplicate I think.
Comment 19 CongLi 2017-02-06 04:23:39 EST
(In reply to Gerd Hoffmann from comment #18)
> > Is there any info we may missed?
> > If no, could we close this bug ?
> 
> Looks very plausible, can be closed as duplicate I think.

Thanks Gerd.

Close this bug as a dup to BZ1252134.

Please be free to reopen it if there is anything wrong.

Thanks.

*** This bug has been marked as a duplicate of bug 1252134 ***

Note You need to log in before you can comment on or make changes to this bug.