Bug 1293246 - [GSS] [RFE] Requesting a ceph-ansible tunable for disabling OSD journal creation. [NEEDINFO]
[GSS] [RFE] Requesting a ceph-ansible tunable for disabling OSD journal creat...
Status: CLOSED WONTFIX
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible (Show other bugs)
1.3.0
x86_64 Linux
medium Severity medium
: rc
: 3.0
Assigned To: leseb
ceph-qe-bugs
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 03:25 EST by Vimal Kumar
Modified: 2017-09-06 15:21 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-31 07:39:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
flucifre: needinfo? (seb)


Attachments (Terms of Use)

  None (edit)
Description Vimal Kumar 2015-12-21 03:25:57 EST
1. Proposed title of this feature request 

Requesting a tunable for disabling OSD journal creation.  
  
2. Who is the customer behind the request?  

Account name : VOLKSWAGEN AG
Account #    : 495233
  
TAM customer : YES
Strategic    : YES

3. What is the nature and description of the request?  

By default 'ceph-deploy' creates the OSD journal on the OSD disk itself (if no journal disks are specified), or creates it on the disks specified.

The customer is using enterprise level SSDs with PFC (Power Fail Circuitry) and these disks guarantee all writes on the SSD write cache and those writes will be persistent even on a power failure.

They need a feature to disable journaling for Ceph, or a tunable with which this can be disabled at the time of OSD creation.

4. Why does the customer need this? (List the business requirements here)  

They want to reduce the number of I/O going on to the disks. If a journal is present, the writes first hit the journal, and subsequently the OSDs. Since the SSDs they use are enterprise grade and support battery-backed caches, they want a feature in ceph-deploy to disable the creation on journals.
  
5. How would the customer like to achieve this? (List the functional requirements here)  

A switch in ceph-deploy to disable the creation of journalling, at the time of OSD preparation.
  
6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  

This can be easily tested both by Red Hat, and the customer.
  
7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  

-NIL-
  
8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  

-NIL-
  
9. Is the sales team involved in this request and do they have any additional input?  

-NIL-
  
10. List any affected packages or components.  

ceph
  
11. Would the customer be able to assist in testing this functionality if implemented? 

Yes
Comment 2 Gregory Meno 2016-02-17 19:21:31 EST
fix this up to be improve ceph-ansible to configure OSDs allowing them to be created without a journal
Comment 5 Federico Lucifredi 2017-07-31 07:39:07 EDT
Ceph-deploy is no longer in active development. Ceph-Ansible replaced it.

Note You need to log in before you can comment on or make changes to this bug.