Bug 1293262 - [RFE] KRBD: Support for more RBD features, e.g. object map, exclusive lock etc.
[RFE] KRBD: Support for more RBD features, e.g. object map, exclusive lock etc.
Status: CLOSED DUPLICATE of bug 1376346
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD (Show other bugs)
1.3.1
x86_64 Linux
medium Severity medium
: rc
: 2.1
Assigned To: Jason Dillaman
ceph-qe-bugs
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 04:14 EST by Vikhyat Umrao
Modified: 2017-07-30 11:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-15 04:31:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2100651 None None None 2015-12-21 04:42 EST

  None (edit)
Description Vikhyat Umrao 2015-12-21 04:14:40 EST
Description of problem:
[RFE] KRBD: Support for more RBD features, e.g. object map, exclusive lock etc

Version-Release number of selected component (if applicable):
Red Hat Ceph Storage 1.3

1. The krbd module does not support exclusive lock / object map / fast-diff / deep flatten / journaling features and also stripping. 
2.  Basically only supports layering
3. Development is in-progress for exclusive lock support and object map support.
Comment 2 Vikhyat Umrao 2015-12-21 04:17:16 EST
Jewel will also get support for mapping RBD images as network block devices (NBD), we will be able to get a raw device that supports all the new features (since it is using librbd via a user-space daemon).

Then NBD could make to Red Hat Ceph Storage 2.0 release which would be Jewel based.
Comment 9 Brett Niver 2016-09-15 04:31:48 EDT
This BZ has been broken up into several more specific BZ that each track one feature request.

https://bugzilla.redhat.com/show_bug.cgi?id=1376346   : Exclusive Lock
https://bugzilla.redhat.com/show_bug.cgi?id=1376349   : Object Map Support
https://bugzilla.redhat.com/show_bug.cgi?id=1376351   : Fast Diff Support
https://bugzilla.redhat.com/show_bug.cgi?id=1376354   : Deep Flatten Support
https://bugzilla.redhat.com/show_bug.cgi?id=1376356   : Journaling Features
https://bugzilla.redhat.com/show_bug.cgi?id=1376358   : Striping Support

*** This bug has been marked as a duplicate of bug 1376346 ***

Note You need to log in before you can comment on or make changes to this bug.