Bug 1293268 - Include openssh-server and openssh-clients package in RHGS container image
Include openssh-server and openssh-clients package in RHGS container image
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhgs-server-container (Show other bugs)
3.1
x86_64 Linux
medium Severity medium
: ---
: RHGS 3.1.2
Assigned To: Mohamed Ashiq
Anoop
: ZStream
Depends On:
Blocks: 1294618
  Show dependency treegraph
 
Reported: 2015-12-21 04:32 EST by Shruti Sampat
Modified: 2016-12-19 12:30 EST (History)
7 users (show)

See Also:
Fixed In Version: rhgs-server-rhel7:3.1.2-5
Doc Type: Bug Fix
Doc Text:
Cause: No openssh-server, openssh-clients, rsync and tar packages in RHGS image. Consequence: Affects Geo-replication in RHGS image. Fix: Adding openssh-server,openssh-client,rsync and tar to the RHGS image. Result: Geo-replication in RHGS image works fine. Packages successfully added to the image.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-19 12:30:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shruti Sampat 2015-12-21 04:32:58 EST
Description of problem:
-----------------------

Passwordless ssh connection is required between master and slave clusters for glusterfs geo-replication to work. SSH server and client packages are required to be installed on the glusterfs storage server for this. They should be part of the RHGS container image, in my opinion. 

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
rhgs-server-rhel7:3.1.2-3

Actual results:
----------------
RHGS container image does not contain openssh-server and openssh-clients packages.

Expected results:
-----------------
RHGS container image should contain openssh-server and openssh-clients packages.
Comment 2 Mohamed Ashiq 2015-12-21 08:55:56 EST
Added the openssh-server and openssh-client packages. Speaking with kotresh, Geo-replication needs rsync and tar packages too. 
All the four packages will be available in the next build.
Comment 3 Humble Chirammal 2016-01-03 00:56:19 EST
@Ashiq, when you build next image, apart from including these packages, can you disable all the repos once the installation of the packages are done in intermediate containers?
Comment 4 Mohamed Ashiq 2016-01-05 06:37:23 EST
@Humble, IMO, Its not necessary to disable the repos after installation.

This bug is delayed due to build failure in rhpkg container build which is fixed now.

https://engineering.redhat.com/rt/Ticket/Display.html?id=385101
Comment 7 Shruti Sampat 2016-01-11 02:14:19 EST
Verified as fixed in rhgs-server-rhel7:3.1.2-5 -

# rpm -qa | grep openssh
openssh-server-6.6.1p1-22.el7.x86_64
openssh-6.6.1p1-22.el7.x86_64
openssh-clients-6.6.1p1-22.el7.x86_64

Note You need to log in before you can comment on or make changes to this bug.