Bug 1293280 - Guru Mediation Report doesn't work on nova-scheduler nor nova-api
Guru Mediation Report doesn't work on nova-scheduler nor nova-api
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity urgent
: ---
: 7.0 (Kilo)
Assigned To: Eoghan Glynn
nlevinki
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 05:18 EST by Daniel Berrange
Modified: 2018-01-25 05:18 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1292787
Environment:
Last Closed: 2018-01-25 05:18:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Daniel Berrange 2015-12-21 05:23:18 EST
As from the SELinux bug, we need to do some fixes to the GMR code to make it more robust & debuggable

 - If an exception occurs while collecting information we must log that so we can more easily diagnose similar problems in future
 - If a single data collector (like the process listing) fails, we should still be able to carry on and report the GMR with all other info, just record an error from the process listing in the GMR
 - There is absolutely no reason to be walking entire of /proc to get all processes. Given the process ID, you can access /proc/$PID/task/NNNN to get all threads that are children. We should see about improving psutil to address this.
Comment 2 Ryan Hallisey 2015-12-21 21:35:09 EST
Can you post the entire log when running in permissive?  Also this bug is for 8.0 correct?  I'm assuming that's why it's cloned here.
Comment 4 Michal Pryc 2018-01-25 05:18:03 EST
There is agreement that bug exists, however I am closing this bug due to following reasons:

 1. The bug is only visible during debugging operation for nova services

 2. There is known work-around which allows debugging to work, see comment below:
    https://bugzilla.redhat.com/show_bug.cgi?id=1292787#c10

 3. Proper fix should be in both nova and python-psutil, however for debug only operation known work-around is sufficient.

 4. Original bug is from 2015 with almost none following requests, which is low priority.

Note You need to log in before you can comment on or make changes to this bug.