Bug 1293286 - heal info output shouldn't print number of entries processed when brick is unreachable.
heal info output shouldn't print number of entries processed when brick is un...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: replicate (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.1.2
Assigned To: Bug Updates Notification Mailing List
RajeshReddy
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 05:44 EST by Anuradha
Modified: 2016-09-19 22:00 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 01:05:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anuradha 2015-12-21 05:44:06 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Anuradha 2015-12-21 05:51:52 EST
Patch posted :
https://code.engineering.redhat.com/gerrit/#/c/64276/1
Comment 4 RajeshReddy 2015-12-24 06:51:46 EST
Tested with build glusterfs-server-3.7.5-13 and once brick is down heal info showing any entries for the given brick 

[root@rhs-client19 test]# gluster vol heal bug_afr1x2 info
Brick rhs-client18.lab.eng.blr.redhat.com:/rhs/brick5/bug_afr1x2_new
Status: Transport endpoint is not connected

Brick rhs-client19.lab.eng.blr.redhat.com:/rhs/brick5/bug_afr1x2_new
Number of entries: 0
Comment 6 errata-xmlrpc 2016-03-01 01:05:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.