Bug 1293293 - afr: warn if pending xattrs missing during init()
afr: warn if pending xattrs missing during init()
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ravishankar N
: Triaged
Depends On:
Blocks: 1293536
  Show dependency treegraph
 
Reported: 2015-12-21 05:57 EST by Ravishankar N
Modified: 2016-06-16 09:51 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1293536 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:51:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravishankar N 2015-12-21 05:57:02 EST
Description of problem:

Since commit 6e635284a4411b816d4d860a28262c9e6dc4bd6a
glusterfs-3.7.7), the afr pending xattrs are stored in the volfile and used
by afr when it initializes. If a cluster is upgraded to 3.7.7 and the volfile is not regenerated, AFR will crash.


How reproducible:
Always

Steps to Reproduce:
1. Create a 1x2 replica on glusterfs 3.7.6 on one node
2. Upgrade to 3.7.7, restart glusterd
3. gluster volume set all cluster.op-version 30707
4. start the volume and fuse mount it.

Actual results:
Fuse mount will crash

Expected results:
Should not crash
Comment 1 Vijay Bellur 2015-12-21 05:58:26 EST
REVIEW: http://review.gluster.org/13038 (afr: warn if pending xattrs missing during init()) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 2 Vijay Bellur 2015-12-21 10:06:45 EST
REVIEW: http://review.gluster.org/13038 (afr: warn if pending xattrs missing during init()) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 3 Vijay Bellur 2015-12-21 23:31:00 EST
COMMIT: http://review.gluster.org/13038 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 4bfbabfdd698e93a1dc1aad5590ed18f10936c55
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Mon Dec 21 10:09:53 2015 +0000

    afr: warn if pending xattrs missing during init()
    
    Since commit 6e635284a4411b816d4d860a28262c9e6dc4bd6a
    (glusterfs-3.7.7), the afr pending xattrs are stored in the volfile and used
    by afr when it initializes. If a cluster is upgraded, prevent afr from loading
    until the op-version has been bumped up to 3.7.7 and the volfiles have been
    regenerated using a volume set command.
    
    Without this fix, AFR will crash when initialzing.
    
    Change-Id: I14249dedb3f2f77cd754d78d8a9a70fdc5fc8c10
    BUG: 1293293
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/13038
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:51:54 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.