Bug 1293309 - [georep+tiering]: Geo-replication sync is broken if cold tier is EC
[georep+tiering]: Geo-replication sync is broken if cold tier is EC
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.0
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Gaurav Kumar Garg
bugs@gluster.org
: ZStream
Depends On: 1292084
Blocks: glusterfs-3.7.7
  Show dependency treegraph
 
Reported: 2015-12-21 06:47 EST by Gaurav Kumar Garg
Modified: 2016-06-05 19:37 EDT (History)
13 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1292084
Environment:
Last Closed: 2016-02-14 09:48:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-21 06:50:24 EST
REVIEW: http://review.gluster.org/13042 (cli/xml: display correct xml output of tier volume) posted (#1) for review on release-3.7 by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 2 Vijay Bellur 2015-12-22 01:31:30 EST
REVIEW: http://review.gluster.org/13059 (geo-rep: Fix getting subvol number) posted (#1) for review on release-3.7 by Kotresh HR (khiremat@redhat.com)
Comment 3 Vijay Bellur 2015-12-22 10:43:39 EST
REVIEW: http://review.gluster.org/13059 (geo-rep: Fix getting subvol number) posted (#2) for review on release-3.7 by Kotresh HR (khiremat@redhat.com)
Comment 4 Vijay Bellur 2015-12-22 10:43:44 EST
REVIEW: http://review.gluster.org/13068 (geo-rep: Fix getting subvol count) posted (#1) for review on release-3.7 by Kotresh HR (khiremat@redhat.com)
Comment 5 Vijay Bellur 2015-12-22 19:29:17 EST
COMMIT: http://review.gluster.org/13042 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 86fa1507a15eb9e1e4a8e1e83785b5a46eee9aa4
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Wed Dec 16 18:04:55 2015 +0530

    cli/xml: display correct xml output of tier volume
    
    This patch is backport of: http://review.gluster.org/#/c/12982/
    
    Currently When hot tier type is distributed-replicate and cold tier
    type is disperse volume then #gluster volume info --xml command is
    not giving its correct output. In case of HOT tier case its displaying
    wrong volume type.
    
    With this fix it will show correct xml output for tier volume
    irrespective of all the type of the volume's.
    
      >> Change-Id: If1de8d52d1e0ef3d0523163abed37b2b571715e8
      >> BUG: 1293309
      >> Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
      >> Reviewed-on: http://review.gluster.org/12982
      >> Tested-by: NetBSD Build System <jenkins@build.gluster.org>
      >> Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
      >> Tested-by: Gluster Build System <jenkins@build.gluster.com>
      >> Reviewed-by: Kotresh HR <khiremat@redhat.com>
      >> Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    
    Change-Id: If1de8d52d1e0ef3d0523163abed37b2b571715e8
    BUG: 1293309
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    (cherry picked from commit b0e126d0edf10946701c2fd4f0f1cf8c7b07eda1)
    Reviewed-on: http://review.gluster.org/13042
    Reviewed-by: hari gowtham <hari.gowtham005@gmail.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 6 Vijay Bellur 2016-01-04 01:06:42 EST
COMMIT: http://review.gluster.org/13059 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit fd26e57537316da736768f32c12058e1e01123ce
Author: Kotresh HR <khiremat@redhat.com>
Date:   Thu Dec 17 12:39:30 2015 +0530

    geo-rep: Fix getting subvol number
    
    Fix getting subvol number if the volume
    type is tier. If the volume type was tier,
    the subvol number was calculated incorrectly
    and hence few of workers didn't become ACTIVE
    resulting in files not being replicated from
    corresponding brick. This patch addresses
    the same.
    
    BUG: 1293309
    Change-Id: I318de346657d330a2394507514bdff61feb92d27
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/12994
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-on: http://review.gluster.org/13059
Comment 7 Vijay Bellur 2016-01-04 01:07:08 EST
COMMIT: http://review.gluster.org/13068 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit beca3d718bbb0851ffa0d07199a4779f50d19fdc
Author: Kotresh HR <khiremat@redhat.com>
Date:   Tue Dec 22 12:29:32 2015 +0530

    geo-rep: Fix getting subvol count
    
    Tiering doesn't support disperse volume as hot tier,
    hence xml output doesn't give 'hotdisperseCount'.
    Remove the usage of 'hotdisperseCount' in geo-rep
    and return 0 instead.
    
    BUG: 1293309
    Change-Id: I3f50d21cb51db91e31faebf69af4f72360420b73
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/13062
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/13068
Comment 8 Gaurav Kumar Garg 2016-02-14 09:48:07 EST
GlusterFS v3.7.8 contains a fix  for this bug, hence closing this bug.
Comment 9 Kaushal 2016-04-19 03:51:26 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.