Bug 1293339 - L3 agent fails to respawn keepalived process
L3 agent fails to respawn keepalived process
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity high
: z4
: 7.0 (Kilo)
Assigned To: Arie Bregman
Ofer Blaut
: ZStream
Depends On: 1287736
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 08:10 EST by Arie Bregman
Modified: 2016-04-26 14:06 EDT (History)
13 users (show)

See Also:
Fixed In Version: openstack-neutron-2015.1.2-7.el7ost
Doc Type: Bug Fix
Doc Text:
Cause: when keepalived crashes unexpectedly, the vrrp process that it associated with, will be orphan process Consequence: neutron is not able to respawn the keepalived process because it thinks it's already running Fix: check and delete the orphan vrrp process if there is any, in the processmonitor of l3 agent Result: L3 agent respawn keepalived process successfully
Story Points: ---
Clone Of: 1287736
Environment:
Last Closed: 2016-02-18 11:09:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1286729 None None None 2015-12-21 08:10 EST
OpenStack gerrit 251693 None None None 2015-12-21 08:10 EST

  None (edit)
Comment 2 Ofer Blaut 2016-01-24 04:41:33 EST
I have killed vrrp process on Active agent host the router and HA occurs, vrrp process are respawn  

openstack-neutron-2015.1.2-7.el7ost.noarch
Comment 6 errata-xmlrpc 2016-02-18 11:09:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0260.html

Note You need to log in before you can comment on or make changes to this bug.