Bug 1293340 - Missing Requires: openssl >= 1.0.1e-42
Missing Requires: openssl >= 1.0.1e-42
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: softhsm (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Spacek
Namita Soman
:
Depends On:
Blocks: 1286635
  Show dependency treegraph
 
Reported: 2015-12-21 08:12 EST by Petr Spacek
Modified: 2016-12-15 11:14 EST (History)
4 users (show)

See Also:
Fixed In Version: softhsm-2.1.0-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-15 11:14:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Spacek 2015-12-21 08:12:47 EST
Description of problem:
SoftHSM package is missing Requires: openssl >= 1.0.1e-42 in the SPEC file.

This is causing problems like e.g. bug 1286635.

Version-Release number of selected component (if applicable):
softhsm-2.0.0rc1-3.el7

How reproducible:
100 %

Steps to Reproduce:
1. yum upgrade softhsm (i.e. avoid explicit upgrade of openssl at the same time)

Actual results:
SoftHSM library does not work.

Expected results:
It should work.
Comment 1 Petr Spacek 2016-01-07 06:32:25 EST
IPA will apply workaround for bug 1286635 for now, so this can be solved in 7.3.0.
Comment 4 Kaleem 2016-09-19 08:33:35 EDT
Verified.

[root@dhcp207-129 ~]# yum deplist softhsm|grep 'dependency: openssl-libs'
  dependency: openssl-libs >= 1.0.1e-42.el7_1.2
  dependency: openssl-libs >= 1.0.1e-42.el7_1.2
  dependency: openssl-libs >= 1.0.1e-42.el7_1.2
[root@dhcp207-129 ~]# rpm -q softhsm
softhsm-2.1.0-2.el7.x86_64
[root@dhcp207-129 ~]#
Comment 5 Petr Spacek 2016-12-15 11:14:08 EST
Fix was released as part of erratum RHEA-2016:2482-03 softhsm bug fix update.

Note You need to log in before you can comment on or make changes to this bug.