Bug 1293342 - Data Tiering:Watermark:File continuously trying to demote itself but failing " [dht-rebalance.c:608:__dht_rebalance_create_dst_file] 0-wmrk-tier-dht: chown failed for //AP.BH.avi on wmrk-cold-dht (No such file or directory)"
Data Tiering:Watermark:File continuously trying to demote itself but failing ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
:
Depends On: 1286218 1292067
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 08:40 EST by Mohammed Rafi KC
Modified: 2016-04-19 03:51 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1292067
Environment:
Last Closed: 2016-04-19 03:51:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-21 08:44:24 EST
REVIEW: http://review.gluster.org/13045 (tier: Demotion failed if the file was renamed when it was in cold) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2015-12-30 11:29:09 EST
COMMIT: http://review.gluster.org/13045 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 7d84f8b95ecfa4f3d68eb0cbe7bd18f4293ec441
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Wed Dec 16 17:16:36 2015 +0530

    tier: Demotion failed if the file was renamed when it was in cold
    
    During migration if the file is present we just open the file
    in hashed subvol. Now if the linkfile present on hashed is just
    linkfile to another subvol, we actually open in hashed subvol.
    
    But subsequent operation will go to linkto subvol ie,
    to non-hashed subvol. This operation will get failed
    since we haven't opened d on non-hashed.
    
    Backport of>
    >Change-Id: I9753ad3a48f0384c25509612ba76e7e10645add3
    >BUG: 1292067
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/12980
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: Susant Palai <spalai@redhat.com>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    >Tested-by: Dan Lambright <dlambrig@redhat.com>
    
    (cherry picked from commit d2f48214d436be633efb1136ee951b0736935143)
    
    
    Change-Id: I562ac4ba73e6b572bc1be91e55a029fa75262b33
    BUG: 1293342
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/13045
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:51:49 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.