Bug 1293348 - first file created after hot tier full fails to create, but gets database entry and later ends up as a stale erroneous file (file with ???????????)
first file created after hot tier full fails to create, but gets database ent...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: Triaged
Depends On: 1289163 1291566
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 08:57 EST by Joseph Elwin Fernandes
Modified: 2016-04-19 03:51 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1291566
Environment:
Last Closed: 2016-04-19 03:51:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-21 09:01:03 EST
REVIEW: http://review.gluster.org/13046 (tier/dht : Properly free file descriptors during data migration) posted (#1) for review on release-3.7 by Joseph Fernandes
Comment 2 Vijay Bellur 2015-12-23 00:14:16 EST
COMMIT: http://review.gluster.org/13046 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 9a198ccd65c067e5269cbdfef0b8fab7073bc212
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Tue Dec 15 13:32:29 2015 +0530

    tier/dht : Properly free file descriptors during data migration
    
    While tier migration, free src and dst fd's when create of
    destination or open of source fails.
    
    Backport of http://review.gluster.org/12969
    
    > Change-Id: I62978a669c6c9fbab5fed9df2716b9b2ba00ddf1
    > BUG: 1291566
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    > Reviewed-on: http://review.gluster.org/12969
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: N Balachandran <nbalacha@redhat.com>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > Tested-by: Dan Lambright <dlambrig@redhat.com>
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    
    Change-Id: I4d745076b3258a64584778ba88dd665ddd907d27
    BUG: 1293348
    Reviewed-on: http://review.gluster.org/13046
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:51:49 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.