Bug 129336 - speedstep-ich: system hangs when setting cpufreq speed
speedstep-ich: system hangs when setting cpufreq speed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-06 12:34 EDT by Jeff Cheng
Modified: 2015-01-04 17:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-11 02:21:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (15.08 KB, text/plain)
2004-08-06 12:35 EDT, Jeff Cheng
no flags Details

  None (edit)
Description Jeff Cheng 2004-08-06 12:34:41 EDT
Description of problem:
When switching between min and max CPU frequencies with speedstep-ich,
the system/X server hangs and I am forced to reboot/poweroff the
system manually. Unfortunately, nothing was found to be logged. I am
running FC2 on a Dell Inspiron 5150 with P4 3Ghz (Northwood) and
Mobility Radeon 9000 video card.  This occurs when trying to set the
speed manually and through cpuspeed.

Version-Release number of selected component (if applicable):
kernel-2.6.7-1.494.2.2
kernel-utils-2.4-9.1.131
xorg-x11-6.7.0-5

How reproducible:
Always

Steps to Reproduce:
1. Boot kernel (speedstep-ich built-in by default).

2. Output from /sys/devices/system/cpu/cpu0/cpufreq/*:
        cpuinfo_cur_freq: 1599960
        cpuinfo_max_freq: 3066590
        cpuinfo_min_freq: 1599960
        scaling_available_frequencies: 3066590 1599960
        scaling_available_governors: userspace performance
        scaling_cur_freq: 1599960
        scaling_driver: speedstep-ich
        scaling_governor: userspace
        scaling_max_freq: 3066590
        scaling_min_freq: 1599960
        scaling_setspeed: 1599960

3. $echo 3066590 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed
     $echo 1599960 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed
     or,
     $killall -SIGUSR1 cpuspeed
     $killall -SIGUSR2 cpuspeed

Actual results:
System becomes unresponsive.

Expected results:
cpu frequency switches between min and max speeds.

Additional info:
Attached dmesg output.
Comment 1 Jeff Cheng 2004-08-06 12:35:39 EDT
Created attachment 102481 [details]
dmesg output
Comment 2 Jeff Cheng 2004-08-19 22:15:41 EDT
Note: the problem still exists with kernel-2.6.8-2.521.
Comment 3 Jeff Cheng 2004-11-11 02:21:00 EST
Seems to be fixed in 2.6.9-1.667.

Note You need to log in before you can comment on or make changes to this bug.