Bug 1293360 - When filesystem name is long, the disk full check fails to work [NEEDINFO]
When filesystem name is long, the disk full check fails to work
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: logwatch (Show other bugs)
7.2
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jan Synacek
Martin Frodl
: Patch
Depends On: 1196774
Blocks: 1289485 1313485
  Show dependency treegraph
 
Reported: 2015-12-21 09:26 EST by Martin Frodl
Modified: 2016-08-30 08:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1196774
Environment:
Last Closed: 2016-05-20 05:09:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mfrodl: needinfo? (jsynacek)


Attachments (Terms of Use)

  None (edit)
Description Martin Frodl 2015-12-21 09:26:00 EST
+++ This bug was initially created as a clone of Bug #1196774 +++

Description of problem:
The logwatch has a perl file zz-disk_space which contains a function DiskFull. This function does a split to separate lines, mostly using the df command. When the filesystem name is long, it appears on a line by itself, with the other fields (Size, Used, Avail, Use%, Mounted on) appearing on the next line. Because of this, the check for the filesystem becoming full looks at the wrong field, and fails to report when the disk is becoming full.


Version-Release number of selected component (if applicable):
logwatch-7.4.0-28.20130522svn140.el7.noarch

How reproducible:
Very

Steps to Reproduce:
1. Go to a host which has a long (> 22 chars) filesystem name.
2. Make its disk usage at or above 90%. Create a big file with truncate or fallocate.
3. sudo logwatch --detail high
Actual results:
No 'Warning. Disk filling up.' message appears.

Expected results:
Something like this:
/dev/mapper/vg_gw-lv_root => 100% Used. Warning. Disk Filling up.

Additional info:
Comment 8 Martin Frodl 2016-05-20 05:09:45 EDT
I took a closer look into the matter and was unable to reproduce this bug with
the latest released version (logwatch-7.4.0-28.20130522svn140.el7.noarch). It
turns out that from coreutils 8.11 on, lines with long filesystem names are no
longer being split in two:

  df now aligns columns consistently, and no longer wraps entries
  with longer device identifiers, over two lines.

  (From http://savannah.gnu.org/forum/forum.php?forum_id=6785)

This means that disk usage info is located consistently (5th column) and
logwatch always prints the 'Disk Filling up' warning when needed, even for
filesystems with monstrously long names.

As there is nothing to fix here, I am closing the bug.
Comment 9 Tom Ekberg 2016-05-20 10:59:54 EDT
I'm not sure why this bug report got resubmitted. The problem was fixed by Jan Synacek on 2015-11-19 02:56:42 EST under bug 1196774.

Note You need to log in before you can comment on or make changes to this bug.