Bug 1293379 - After updating from 7.0 to 7.2 nodes are not configured as static IP
After updating from 7.0 to 7.2 nodes are not configured as static IP
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity urgent
: ---
: 10.0 (Newton)
Assigned To: Dan Sneddon
Shai Revivo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 10:41 EST by Ronnie Rasouli
Modified: 2016-09-12 23:01 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
There is currently a known issue where network configuration changes can cause interface restarts, resulting in an interruption of network connectivity on overcloud nodes. Consequently, the network interruption can cause outages in the pacemaker controller cluster, leading to nodes being fenced (if fencing is configured). As a result, tripleo-heat-templates is designed to not apply network configuration changes on overcloud updates. By not applying any network configuration changes, the unintended consequence of a cluster outage is avoided.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-12 14:00:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronnie Rasouli 2015-12-21 10:41:47 EST
Description of problem:

In version 7.0 there was no deployment parameter to set the nodes with static IP, however there is a pad to update the nic-configs for each node http://openstack.etherpad.corp.redhat.com/rhel-osp-director-puddle-2015-12-16-1

parameters:
  ControlPlaneIp:
    default: ''
    description: IP address/subnet on the ctlplane network
    type: string
  ControlPlaneSubnetCidr:
    default: '24'
    description: The subnet CIDR of the control plane network.
    type: string
  EC2MetadataIp:
    description: The IP address of the EC2 metadata server.
    type:  string

In addition having in update the following yaml file for new environment parameters:

~/templates/param-updates.yaml
http://file.bne.redhat.com/~dmacpher/OpenStack/7.0/BZ1286798/#sect-New_Environment_Params

However, after the update command:

Deploy command:

openstack overcloud deploy --templates ~/templates/my-overcloud   --control-scale 3 --compute-scale 2 --ntp-server clock.redhat.com   --libvirt-type qemu --debug --log-file=overcloud_deploy.log  -e ~/templates/my-overcloud/environments/network-isolation.yaml  -e ~/templates/network-environment.yaml  -e ~/templates/firstboot-environment.yaml

update command:


/usr/bin/yes '' | openstack overcloud update stack overcloud -i \
         --templates ~/templates/my-overcloud \
         -e ~/templates/my-overcloud/overcloud-resource-registry-puppet.yaml \
         -e ~/templates/my-overcloud/environments/network-isolation.yaml \
         -e ~/templates/network-environment.yaml \
         -e ~/templates/firstboot-environment.yaml \
	 -e ~/templates/param-updates.yaml \
         -e ~/templates/my-overcloud/environments/updates/update-from-keystone-admin-internal-api.yaml

The nodes configured as DHCP

cat /etc/sysconfig/network-scripts/ifcfg-br-ex 
# This file is autogenerated by os-net-config
DEVICE=br-ex
ONBOOT=yes
HOTPLUG=no
NM_CONTROLLED=no
DEVICETYPE=ovs
TYPE=OVSBridge
OVSBOOTPROTO=dhcp


Version-Release number of selected component (if applicable):

7.0 GA 
updated to puddle-2015-12-16-1

How reproducible:

100%

Steps to Reproduce:
1.deploy 7.0 HA with network isolation
2.modify the nodes nic-configs with setting above
3.update using the update command above

Actual results:

Update successful however the nic configs has no static IP

Expected results:

Update should set the network interfaces to static during the update process.

Additional info:
Comment 2 Ofer Blaut 2015-12-21 10:51:11 EST
 DnsServers: parameter should be used as well
Comment 3 Mike Burns 2016-04-07 17:00:12 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 Dan Sneddon 2016-07-12 14:00:20 EDT
The instructions listed in the Etherpad (http://openstack.etherpad.corp.redhat.com/rhel-osp-director-puddle-2015-12-16-1?) are only intended to allow an upgrade to complete. The instructions are not sufficient to convert to static IP addresses.

In order to switch to static IP addresses on the Provisioning net, you need to configure the Provisioning Interface to use a static IP. See the sample network interface config templates in openstack-tripleo-heat-templates/network/config/* for examples of configuring a static Provisioning (Control Plane) IP.

Note You need to log in before you can comment on or make changes to this bug.