Bug 1293399 - [RFE] Certificate Tool: Modify [NEEDINFO]
[RFE] Certificate Tool: Modify
Status: CLOSED DUPLICATE of bug 1293395
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike Barrett
Johnny Liu
:
Depends On: 1293395
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 11:49 EST by Eric Jones
Modified: 2016-04-14 16:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
OpenShift Enterprise 3.1
Last Closed: 2016-04-14 16:14:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
erjones: needinfo? (mbarrett)


Attachments (Terms of Use)

  None (edit)
Description Eric Jones 2015-12-21 11:49:33 EST
- What is the nature and description of the request?  
As an admin I need the ability to add or remove certificates and certificate authorities from my .kube/config so that I can take advantage of using multiple CAs, including private ones.

- Why does the customer need this? (List the business requirements here)  
So that they can add to the CA they are using. This could come up if you add a Load Balancer that is using a different CA from the rest of your environment. This is already a case with a customer.

- How would the customer like to achieve this? (List the functional requirements here)  
Add an oc or kube command that can modify the CAs, certificates,and keys listed in the .kube/config on each node/master.
The ability to Modify, or add to/remove from, the current features. 

- Is there already an existing RFE upstream or in Red Hat Bugzilla?  
Not that I could find  

- List any affected packages or components.  
OpenShift
Kubernetes
Comment 3 Dan McPherson 2016-04-14 16:14:15 EDT

*** This bug has been marked as a duplicate of bug 1293395 ***

Note You need to log in before you can comment on or make changes to this bug.