Bug 1293400 - [RFE] Certificate Tool: Edit
[RFE] Certificate Tool: Edit
Status: CLOSED DUPLICATE of bug 1293395
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike Barrett
Johnny Liu
:
Depends On: 1293395
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 11:55 EST by Eric Jones
Modified: 2016-04-14 07:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
OpenShift Enterprise 3.1
Last Closed: 2016-04-14 07:54:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Jones 2015-12-21 11:55:24 EST
- What is the nature and description of the request?  
As an admin I need the ability to change the current certificates and certificate authorities from my .kube/config to a different one so that once my certificates expire, I can change them all easily or other similar situations.

- Why does the customer need this? (List the business requirements here)  
So that they can change the CA they are using. This could be related to expiring certificates.

- How would the customer like to achieve this? (List the functional requirements here)  
Add an oc or kube command that can edit(change) the CAs, certificates,and keys listed in the .kube/config on each node/master. 

- Is there already an existing RFE upstream or in Red Hat Bugzilla?  
Not that I could find  

- List any affected packages or components.  
OpenShift
Kubernetes
Comment 2 Dan McPherson 2016-04-14 07:54:45 EDT

*** This bug has been marked as a duplicate of bug 1293395 ***

Note You need to log in before you can comment on or make changes to this bug.