Bug 1293413 - Document how to have ansible set garbage_collection parameters for a cluster.
Document how to have ansible set garbage_collection parameters for a cluster.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Alex Dellapenta
Vikram Goyal
Vikram Goyal
:
Depends On: 1293397
Blocks: 1299023
  Show dependency treegraph
 
Reported: 2015-12-21 12:31 EST by Eric Rich
Modified: 2016-08-01 09:29 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1293397
: 1299023 (view as bug list)
Environment:
Last Closed: 2016-04-25 22:05:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Rich 2015-12-21 12:31:35 EST
+++ This bug was initially created as a clone of Bug #1293397 +++

Description of problem:

Customers who need / wish to set up GC (https://docs.openshift.com/enterprise/3.1/admin_guide/garbage_collection.html) for there environment often run into [0] ([1] is one solution to this). 

Because ansible overwrites or alters the configuration (after GC is configured - directly on the hosts) you loose your GC configuration. 

Version-Release number of selected component (if applicable): 3.1

How reproducible: 100% 

Steps to Reproduce:

1. Passing: openshift_node_kubelet_arguments = [{'image-high-gc-threshold': '90'}, {'image-gc-low-threshold': '80'}] 

Actual results:

This does not seem to be parsable to yaml in the installer. 

Expected results:

This should set the GC configuration based on [2] and [3]. 

Additional info:

[0] https://bugzilla.redhat.com/show_bug.cgi?id=1292961
[1] https://github.com/openshift/openshift-ansible/pull/1095
[2] https://github.com/openshift/openshift-ansible/blob/master/roles/openshift_node/templates/node.yaml.v1.j2#L14-L16
[3] https://github.com/openshift/openshift-ansible/blob/master/roles/openshift_node/tasks/main.yml#L26

--- Additional comment from Andrew Butcher on 2015-12-21 12:26:56 EST ---

Instead of a list, arguments are passed as a dictionary with list values.

openshift_node_kubelet_args={'image-gc-high-threshold': ['90'], 'image-gc-low-threshold': ['80']}
Comment 1 Ryan Howe 2015-12-21 14:05:47 EST
We might want to expanded this to point out KubeletArguments are key value pairs that will be passed directly to the Kubelet that match the Kubelet's command line arguments.  These are not migrated or validated, so if you use them they may become invalid. These values override other settings in NodeConfig which may cause invalid configurations [1].

http://kubernetes.io/v1.0/docs/admin/kubelet.html

[1] https://github.com/openshift/origin/blob/master/pkg/cmd/server/api/v1/types.go#L59-L62
Comment 2 Andrew Butcher 2016-01-04 09:41:43 EST
Documentation pull request: https://github.com/openshift/openshift-docs/pull/1372
Comment 3 Alex Dellapenta 2016-01-04 15:15:23 EST
Merged https://github.com/openshift/openshift-docs/pull/1372, should go out w/ the next weekly OSE publish.
Comment 4 Vikram Goyal 2016-04-25 22:05:01 EDT
Can be verified here [1].

Moving this to CLOSED-->CURRENTRELEASE.

[1] https://docs.openshift.com/enterprise/3.1/admin_guide/garbage_collection.html

Note You need to log in before you can comment on or make changes to this bug.