Bug 1293463 - [RFE] Improve User Experience in Insights when the User is Unauthenticated
[RFE] Improve User Experience in Insights when the User is Unauthenticated
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: rubygem-foreman-redhat_access (Show other bugs)
Unspecified
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Lindani Phiri
jcallaha
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 14:35 EST by Keith Robertson
Modified: 2016-07-27 05:21 EDT (History)
5 users (show)

See Also:
Fixed In Version: rubygem-foreman-redhat_access-1.0.0-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:21:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error message (91.43 KB, image/png)
2016-04-26 14:26 EDT, jcallaha
no flags Details

  None (edit)
Description Keith Robertson 2015-12-21 14:35:19 EST
Try not to show a vanilla 4xx page error when the user doesn't have the necessary auth tokens.
Comment 2 Lindani Phiri 2016-02-02 17:22:20 EST
More actionable message given to user when Insights is disabled for an organization
Comment 5 jcallaha 2016-04-26 14:26:09 EDT
Verified in Satellite 6.2 Beta Snap 9 Compose 2. An appropriate error message is now presented. See below and attached screenshot.

"There was an error retrieving data.
Authentication to the Insights Service failed."
Comment 6 jcallaha 2016-04-26 14:26 EDT
Created attachment 1151057 [details]
error message
Comment 10 errata-xmlrpc 2016-07-27 05:21:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.