Bug 1293488 - SELinux is preventing /usr/bin/composite from 'create' accesses on the file magickm758JF.
SELinux is preventing /usr/bin/composite from 'create' accesses on the file m...
Status: CLOSED DUPLICATE of bug 825874
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Alexeev
Fedora Extras Quality Assurance
abrt_hash:22522176ff5850bd2d1df897356...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 16:53 EST by Markus Schulze
Modified: 2016-01-04 06:57 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 06:57:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markus Schulze 2015-12-21 16:53:22 EST
Description of problem:
SELinux is preventing /usr/bin/composite from 'create' accesses on the file magickm758JF.

*****  Plugin catchall (100. confidence) suggests   **************************

If sie denken, dass es composite standardmässig erlaubt sein sollte, create Zugriff auf magickm758JF file zu erhalten.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
# grep composite /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                magickm758JF [ file ]
Source                        composite
Source Path                   /usr/bin/composite
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ImageMagick-6.8.8.10-9.fc22.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-128.21.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.7-200.fc22.x86_64 #1 SMP Thu
                              Dec 10 03:28:47 UTC 2015 x86_64 x86_64
Alert Count                   28
First Seen                    2015-12-21 22:52:02 CET
Last Seen                     2015-12-21 22:52:03 CET
Local ID                      1f2d737f-abea-4cf1-a06a-55b4cfbc31c3

Raw Audit Messages
type=AVC msg=audit(1450734723.501:1904): avc:  denied  { create } for  pid=8191 comm="convert" name="magickm758JF" scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file permissive=0


type=SYSCALL msg=audit(1450734723.501:1904): arch=x86_64 syscall=open success=no exit=EACCES a0=1d96dd0 a1=c2 a2=180 a3=0 items=0 ppid=8161 pid=8191 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=tty2 ses=1 comm=convert exe=/usr/bin/convert subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)

Hash: composite,thumb_t,user_home_dir_t,file,create

Version-Release number of selected component:
selinux-policy-3.13.1-128.21.fc22.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.7-200.fc22.x86_64
type:           libreport

Potential duplicate: bug 825874
Comment 1 Lukas Vrabec 2016-01-04 06:57:03 EST

*** This bug has been marked as a duplicate of bug 825874 ***

Note You need to log in before you can comment on or make changes to this bug.