Bug 1293494 - [abrt] qbittorrent: QXcbWindow::setParent(): qbittorrent killed by SIGSEGV
[abrt] qbittorrent: QXcbWindow::setParent(): qbittorrent killed by SIGSEGV
Status: CLOSED DUPLICATE of bug 1291003
Product: Fedora
Classification: Fedora
Component: qbittorrent (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabio Alessandro Locati
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:e093fcf47b0a02ff18306c69bcf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 17:32 EST by Artur Cuvasov
Modified: 2016-01-01 23:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-01 23:32:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (70.87 KB, text/plain)
2015-12-21 17:32 EST, Artur Cuvasov
no flags Details
File: cgroup (190 bytes, text/plain)
2015-12-21 17:32 EST, Artur Cuvasov
no flags Details
File: core_backtrace (16.38 KB, text/plain)
2015-12-21 17:32 EST, Artur Cuvasov
no flags Details
File: dso_list (16.75 KB, text/plain)
2015-12-21 17:32 EST, Artur Cuvasov
no flags Details
File: environ (1.79 KB, text/plain)
2015-12-21 17:32 EST, Artur Cuvasov
no flags Details
File: limits (1.29 KB, text/plain)
2015-12-21 17:32 EST, Artur Cuvasov
no flags Details
File: maps (78.27 KB, text/plain)
2015-12-21 17:32 EST, Artur Cuvasov
no flags Details
File: mountinfo (3.33 KB, text/plain)
2015-12-21 17:32 EST, Artur Cuvasov
no flags Details
File: namespaces (85 bytes, text/plain)
2015-12-21 17:32 EST, Artur Cuvasov
no flags Details
File: open_fds (4.58 KB, text/plain)
2015-12-21 17:32 EST, Artur Cuvasov
no flags Details
File: proc_pid_status (1017 bytes, text/plain)
2015-12-21 17:32 EST, Artur Cuvasov
no flags Details
File: var_log_messages (299 bytes, text/plain)
2015-12-21 17:32 EST, Artur Cuvasov
no flags Details

  None (edit)
Description Artur Cuvasov 2015-12-21 17:32:22 EST
Description of problem:
Open settings and try to change download folder.

Version-Release number of selected component:
qbittorrent-3.3.1-2.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        qbittorrent
crash_function: QXcbWindow::setParent
executable:     /usr/bin/qbittorrent
global_pid:     18531
kernel:         4.2.7-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 QXcbWindow::setParent at qxcbwindow.cpp:1499
 #1 QWindow::setParent at kernel/qwindow.cpp:614
 #2 QWidgetPrivate::setParent_sys at kernel/qwidget.cpp:10543
 #3 QWidget::setParent at kernel/qwidget.cpp:10398
 #5 QDialogButtonBox::addButton at widgets/qdialogbuttonbox.cpp:761
 #6 KDEPlatformFileDialog::KDEPlatformFileDialog at ../../../src/platformtheme/kdeplatformfiledialoghelper.cpp:103
 #7 KDEPlatformFileDialogHelper::KDEPlatformFileDialogHelper at ../../../src/platformtheme/kdeplatformfiledialoghelper.cpp:201
 #8 KdePlatformTheme::createPlatformDialogHelper at ../../../src/platformtheme/kdeplatformtheme.cpp:269
 #9 QDialogPrivate::platformHelper at dialogs/qdialog.cpp:94
 #10 QFileDialogPrivate::platformFileDialogHelper at dialogs/qfiledialog_p.h:112
Comment 1 Artur Cuvasov 2015-12-21 17:32:28 EST
Created attachment 1108504 [details]
File: backtrace
Comment 2 Artur Cuvasov 2015-12-21 17:32:29 EST
Created attachment 1108505 [details]
File: cgroup
Comment 3 Artur Cuvasov 2015-12-21 17:32:31 EST
Created attachment 1108506 [details]
File: core_backtrace
Comment 4 Artur Cuvasov 2015-12-21 17:32:32 EST
Created attachment 1108507 [details]
File: dso_list
Comment 5 Artur Cuvasov 2015-12-21 17:32:34 EST
Created attachment 1108508 [details]
File: environ
Comment 6 Artur Cuvasov 2015-12-21 17:32:35 EST
Created attachment 1108509 [details]
File: limits
Comment 7 Artur Cuvasov 2015-12-21 17:32:38 EST
Created attachment 1108510 [details]
File: maps
Comment 8 Artur Cuvasov 2015-12-21 17:32:39 EST
Created attachment 1108511 [details]
File: mountinfo
Comment 9 Artur Cuvasov 2015-12-21 17:32:40 EST
Created attachment 1108512 [details]
File: namespaces
Comment 10 Artur Cuvasov 2015-12-21 17:32:42 EST
Created attachment 1108513 [details]
File: open_fds
Comment 11 Artur Cuvasov 2015-12-21 17:32:43 EST
Created attachment 1108514 [details]
File: proc_pid_status
Comment 12 Artur Cuvasov 2015-12-21 17:32:45 EST
Created attachment 1108515 [details]
File: var_log_messages
Comment 13 Rex Dieter 2016-01-01 23:32:22 EST

*** This bug has been marked as a duplicate of bug 1291003 ***

Note You need to log in before you can comment on or make changes to this bug.