Bug 1293497 - lightdm is missing the user_login audit event
lightdm is missing the user_login audit event
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lightdm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: FutureFeature, Patch, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 18:01 EST by Steve Grubb
Modified: 2016-04-03 17:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: lightdm-1.10.6-2.fc23 lightdm-1.10.6-2.fc22
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 16:51:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
user_login audit patch (5.92 KB, patch)
2015-12-21 18:04 EST, Steve Grubb
no flags Details | Diff

  None (edit)
Description Steve Grubb 2015-12-21 18:01:27 EST
Description of problem:
Lightdm is missing the user_login audit event. Without the event, user login sessions can't be properly located in the audit trail.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. login
2. as root, ausearch --start today -m user_login -x lightdm
3.

Actual results:
No results

Expected results:
an event

Additional info:
Will attach a patch that was sent upstream.
Comment 1 Steve Grubb 2015-12-21 18:04 EST
Created attachment 1108521 [details]
user_login audit patch

This patch adds the missing event. It should be safe to add from a selinux policy view since its already allowing audit events via pam.
Comment 2 Jan Kurik 2016-02-24 09:10:05 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Rex Dieter 2016-03-24 10:00:37 EDT
Rats, seems your patch doesn't apply cleanly to lightdm-1.10.6 , lemme check how bad it is.
Comment 4 Rex Dieter 2016-03-24 10:02:18 EDT
Ah, looks like at least some libaudit support was added in 1.10.6 release, do you know offhand if that is sufficient to satisfy you (and this bug)?
Comment 5 Rex Dieter 2016-03-24 10:41:59 EDT
OK, I found the thread,
https://lists.freedesktop.org/archives/lightdm/2015-December/000911.html

I'm going to guess (hope) the answer is yes, please re-open if that is not the case.
Comment 6 Steve Grubb 2016-03-24 10:51:25 EDT
This bug was against the older releases. Fedora 22/23's auditing is broken for Cinnamon because we cannot tell a user session from a cron job because of the missing event. As for the upstream audit event, I have not looked at it yet because it was not applicable to Fedora. When I see this event, then I'll know if upstream got it right.
Comment 7 Rex Dieter 2016-03-24 10:54:04 EDT
OK, I'll submit f22/f23 1.10.6 updates for testing
Comment 8 Fedora Update System 2016-03-24 10:56:44 EDT
lightdm-1.10.6-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-97272d76c4
Comment 9 Steve Grubb 2016-03-24 11:40:38 EDT
Thanks. When I see it in testing, I'll pull it and give it karma. If something is wrong with the event, I'll contact upstream.
Comment 10 Fedora Update System 2016-03-24 11:44:49 EDT
lightdm-1.10.6-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3c5c785f39
Comment 11 Fedora Update System 2016-03-25 19:48:18 EDT
lightdm-1.10.6-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3c5c785f39
Comment 12 Fedora Update System 2016-03-26 11:20:10 EDT
lightdm-1.10.6-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-97272d76c4
Comment 13 Fedora Update System 2016-03-30 16:51:23 EDT
lightdm-1.10.6-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2016-04-03 17:48:33 EDT
lightdm-1.10.6-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.