Bug 1293539 - rhel7 instalation creates two network devices for just one network device
rhel7 instalation creates two network devices for just one network device
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
All Linux
high Severity medium
: rc
: ---
Assigned To: Jiri Konecny
Release Test Team
:
Depends On:
Blocks: 1493093
  Show dependency treegraph
 
Reported: 2015-12-22 00:25 EST by Masahiro Matsuya
Modified: 2017-09-19 07:13 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-21.48.22.60-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1493093 (view as bug list)
Environment:
Last Closed: 2016-11-03 19:21:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Masahiro Matsuya 2015-12-22 00:25:01 EST
Description of problem:
A customer saw a problem that two network devices were activated for just one network device in RHEL7.2 installation. And, I could reproduce the problem with the following boot pameters.
  
   ks=file:/ks.cfg ifname=provisioning:52:54:00:48:8b:3f bootdev=provisioning ip=provisioning:dhcp

 -> rename the network device with 52:54:00:48:8b:3f into "provisioning"
 -> kickstart file "ks.cfg" is in the local.

And, the kickstart has the following network command.

   network --device 52:54:00:48:8b:3f --bootproto dhcp --noipv6

This network command is for the same network device specified in the boot parameter.

In this case, kickstart is parsed in dracut-cmdline hook, and the network devices are not avialable at that time. So, it cannot find the network device with 52:54:00:48:8b:3f, and it named it 'ksdev0' as another network device.
This causes to create wait-ksdev0.sh in initqueue/finished, and it never finish since such a device doesn't exist in the system.

I thought the kickstart file should be parsed in initqueue even if it's in initrd.img.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 7.2

How reproducible:
Always

Steps to Reproduce:
1. create kickstart file with the following network command.

network --device 52:54:00:48:8b:3f --bootproto dhcp --noipv6

 NOTE: use a proper MAC address in the test machine

2. locate the kickstat file into initrd.img of rhel7.2 as /ks.cfg
3. rebuild rhel7.2 installation iso with the initrd.img
4. use this boot parameter

  ks=file:/ks.cfg ifname=provisioning:52:54:00:48:8b:3f bootdev=provisioning ip=provisioning:dhcp

 NOTE: use a proper MAC address. use a proper nameserver IP address

5. and start rhel7.2 installation 

Actual results:
The installation stops in initqueue phase, since it never see ksdev0.

Expected results:
The device speicifed in boot paramter and one specified in kickstart is recognized as just one network device with the name specfied in boot paramter 'provisioning'.
Comment 1 Harald Hoyer 2016-01-07 05:18:08 EST
hmm, ksdev0 is wanted by the anaconda dracut part.
Comment 11 errata-xmlrpc 2016-11-03 19:21:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html

Note You need to log in before you can comment on or make changes to this bug.