Bug 1293558 - gluster cli crashed while performing 'gluster vol bitrot <vol_name> scrub status'
gluster cli crashed while performing 'gluster vol bitrot <vol_name> scrub sta...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: bitrot (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Satish Mohan
bugs@gluster.org
: Reopened, ZStream
Depends On: 1292705
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 01:47 EST by Gaurav Kumar Garg
Modified: 2016-06-16 09:51 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1292705
Environment:
Last Closed: 2016-06-16 09:51:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-22 01:48:22 EST
REVIEW: http://review.gluster.org/13060 (cli: should not dereference NULL pointer while printing bitrot scrub status) posted (#1) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 2 Vijay Bellur 2015-12-22 02:08:34 EST
REVIEW: http://review.gluster.org/13060 (cli: should not dereference NULL pointer while printing bitrot scrub status) posted (#2) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 3 Vijay Bellur 2015-12-22 02:25:05 EST
REVIEW: http://review.gluster.org/13060 (cli: should not dereference NULL pointer while printing bitrot scrub status) posted (#3) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 4 Vijay Bellur 2015-12-28 09:59:27 EST
COMMIT: http://review.gluster.org/13060 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit e4de816ae126b62906afcc1ce1216500b517e222
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Tue Dec 22 12:05:39 2015 +0530

    cli: should not dereference NULL pointer while printing bitrot scrub status
    
    When user execute bitrot scrub status command and scrubber is
    pending to do scrubbing then value of last_scrub time will be NULL.
    Currently cli is dereferencing NULL pointer in this case, That might
    lead to crash.
    
    Fix is to use proper check condition while printing scrub status.
    
    Change-Id: I3c4be8e25d089451c6ab77b16737c01d0348ee70
    BUG: 1293558
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Reviewed-on: http://review.gluster.org/13060
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 7 Niels de Vos 2016-06-16 09:51:54 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.