Bug 1293586 - [RFE] Use symbolic links instead of copying container image layers
[RFE] Use symbolic links instead of copying container image layers
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Unspecified
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 04:47 EST by Dirk Herrmann
Modified: 2016-10-26 13:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-26 13:54:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dirk Herrmann 2015-12-22 04:47:17 EST
Description of problem:

Currently Satellite6 synchronize entire container image repositories and use copies for each content view and lifecycle environment combination:

[root@inf60 ~]# du -sh /var/lib/pulp/nodes/published/https/repos/*rhel-base
589M	/var/lib/pulp/nodes/published/https/repos/acme-container_images-rhel-base
468M	/var/lib/pulp/nodes/published/https/repos/acme-library-ccv-infra-openshift3-container_images-rhel-base
468M	/var/lib/pulp/nodes/published/https/repos/acme-library-cv-app-ose3-container_images-rhel-base
468M	/var/lib/pulp/nodes/published/https/repos/acme-library-cv-con-webshop-container_images-rhel-base
468M	/var/lib/pulp/nodes/published/https/repos/acme-web-dev-cv-app-ose3-container_images-rhel-base
468M	/var/lib/pulp/nodes/published/https/repos/acme-web-dev-cv-con-webshop-container_images-rhel-base
468M	/var/lib/pulp/nodes/published/https/repos/acme-web-qa-cv-app-ose3-container_images-rhel-base

Since container image repositories are quite big from a storage consumption perspective this leads to an unnecessary huge storage consumption if many container image repos and content views are used.

Version-Release number of selected component (if applicable):

6.1

How reproducible:

Sync a container image repository. Add it to one or more content views and promote them. Verify disk usage inside pulp.

Steps to Reproduce:
1.
2.
3.

Actual results:

Repositories are copied.

Expected results:

Repositories are linked only.

Additional info:
Comment 1 Bryan Kearney 2016-07-26 15:07:33 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 5 Bryan Kearney 2016-10-26 13:54:52 EDT
Closing this out, as it is resolved in 6.2.

Note You need to log in before you can comment on or make changes to this bug.