Bug 1293591 - v2v: external provider "test" button failed when using "any data center" value.
v2v: external provider "test" button failed when using "any data center" value.
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.1
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.1.0-alpha
: 4.1.0.2
Assigned To: Shahar Havivi
Nisim Simsolo
: UserExperience
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 05:08 EST by Nisim Simsolo
Modified: 2017-02-01 09:36 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-01 09:36:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
rule-engine: planning_ack+
rule-engine: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)
engine.log (512.28 KB, application/x-gzip)
2015-12-22 05:11 EST, Nisim Simsolo
no flags Details
vdsm.log (936.15 KB, application/x-gzip)
2015-12-22 05:11 EST, Nisim Simsolo
no flags Details
new engine.log (11.29 MB, application/x-gzip)
2016-01-31 08:04 EST, Nisim Simsolo
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 59426 master MERGED engine: test external provider failed when not selection data-center 2016-06-21 02:42 EDT

  None (edit)
Description Nisim Simsolo 2015-12-22 05:08:46 EST
Description of problem:
- Trying to "test" valid VMware environment from add external provider dialog, 
failed with java.lang.NullPointerException ERROR.
- This issue is relevant only when selecting "any data center" in data center dropbox.
- It is possible to add VMware provider with or without selecting DC in data center dropbox.

Version-Release number of selected component (if applicable):
rhevm-3.6.1.3-0.1.el6
sanlock-3.2.4-1.el7.x86_64
libvirt-client-1.2.17-13.el7_2.2.x86_64
qemu-kvm-rhev-2.3.0-31.el7_2.4.x86_64
vdsm-4.17.13-1.el7ev.noarch


How reproducible:
100%

Steps to Reproduce:
1. Browse webadmin and navigate to left pane -> external provider -> add
2. Enter valid VMware parameters, leave data center dropbox with "any data center" value.
3. click test.
4. Select DC in data center dropbox and click test button.
5. select "any data center" in data center dropbox and click ok.

Actual results:
3. Action failed. engine.log shows java.lang.NullPointerException ERROR
4. Test passed.
5. VMware environment added properly. also VMware VMs can be queried and imported using this provider.

Expected results:
Test should pass also when using "any data center" value.

Additional info:
engine and vdsm log attached.
engine events timing: 
test without selecting DC - 2015-12-22 11:52:41,464
test with DC selected - 2015-12-22 11:53:10,302
clicking ok without selecting DC - 2015-12-22 11:53:39,866
Comment 1 Nisim Simsolo 2015-12-22 05:11 EST
Created attachment 1108604 [details]
engine.log
Comment 2 Nisim Simsolo 2015-12-22 05:11 EST
Created attachment 1108605 [details]
vdsm.log
Comment 3 Michal Skrivanek 2016-01-29 08:34:04 EST
(In reply to Nisim Simsolo from comment #1)
> Created attachment 1108604 [details]
> engine.log

log does not contain the interval you mention. Please attach relevant log
Comment 4 Red Hat Bugzilla Rules Engine 2016-01-29 08:44:09 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 5 Nisim Simsolo 2016-01-31 08:04 EST
Created attachment 1119881 [details]
new engine.log
Comment 6 Nisim Simsolo 2016-01-31 08:08:02 EST
Please see engine.log_new.gz --> 2016-01-31 14:56:42,923 ERROR [org.ovirt.engine.core.bll.GetVmsFromExternalProviderQuery] (ajp-/127.0.0.1:8702-5) [2340e6e9] Exception: java.lang.NullPointerException
Comment 7 Moran Goldboim 2016-03-27 05:15:32 EDT
postponing this one for next release due to capacity.
Comment 9 Sandro Bonazzola 2016-12-12 08:55:38 EST
The fix for this issue should be included in oVirt 4.1.0 beta 1 released on December 1st. If not included please move back to modified.
Comment 10 Nisim Simsolo 2016-12-29 09:26:43 EST
Verification builds:
rhevm-4.1.0-0.3.beta2.el7
qemu-kvm-rhev-2.6.0-28.el7_3.2.x86_64
libvirt-client-2.0.0-10.el7_3.2.x86_64
vdsm-4.19.1-1.el7ev.x86_64
virt-v2v-1.32.7-3.el7.x86_64

Verified with the next external providers:
VMware
KVM (qemu+ssh and qemu+tcp)
Xen

Note You need to log in before you can comment on or make changes to this bug.