Bug 1293633 - An exception is generated when moving hosts into maintenance mode
An exception is generated when moving hosts into maintenance mode
Status: CLOSED WORKSFORME
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.1.3
x86_64 Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: Oved Ourfali
Pavel Novotny
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 08:35 EST by Kevin Alon Goldblatt
Modified: 2016-02-03 07:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-21 12:42:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
gklein: ovirt‑3.6.z?
gklein: blocker?
kgoldbla: planning_ack?
kgoldbla: devel_ack?
kgoldbla: testing_ack?


Attachments (Terms of Use)
engine, vdsm, server logs (2.51 MB, application/x-gzip)
2015-12-22 08:39 EST, Kevin Alon Goldblatt
no flags Details

  None (edit)
Description Kevin Alon Goldblatt 2015-12-22 08:35:28 EST
Description of problem:
On a system with compatibility version 3.5 on the DC and Cluster, with engines and hosts with 3.6.1.7. When moving my hosts into maintenance mode and exception occurs

Version-Release number of selected component (if applicable):
rhevm-3.6.1.3-0.1.el6.noarch
vdsm-4.17.13-1.el7ev.noarch


How reproducible:
Reproduced this on 4 attempts on different hosts and different browsers


Steps to Reproduce:
1. DC and Cluster compatibility version 3.5
2. Via the Webadmin -> Select DC in the tree -> select a host - currently installed with 3.5 and move it to maintenance mode >>>>> The exception below is generated

Actual results:
An exception is generated when moving the host into maintenance mode

Expected results:
The exception should not be generated

Additional info:

SEE BELOW FOR THE CONSOLE OUTPUT FROM 2 DIFFERENT BROWSERS (firefox and cromimum)
====================================================================================

FROM THE FIREFOX BROWSER CONSOLE:
--------------------------------------------------------------------------------------

"[CustomizableUI]" "Custom widget with id loop-button does not return a valid node" CustomizableUI.jsm:167
"!!! start polite load" main.js:21:4
"!!! scripts loaded callback" main.js:32:4
 main.js:59:4
"[CustomizableUI]" "Custom widget with id loop-button does not return a valid node" CustomizableUI.jsm:167
"------------------------------------- Loading package: MailCore" zimbra:1552:0
"------------------------------------- Loading package: Startup2" zimbra:1552:0
"------------------------------------- Loading package: CalendarCore, Calendar" zimbra:1552:0
"------------------------------------- Loading package: Zimlet" zimbra:1552:0
"------------------------------------- Loading package: ContactsCore" zimbra:1552:0
"------------------------------------- Loading package: Contacts" zimbra:1552:0
"------------------------------------- Loading package: TasksCore" zimbra:1552:0
"------------------------------------- Loading package: Alert" zimbra:1552:0
"Your are trying to create a ToggleBlock with selector '.twixi'.One already exists with this trigger so has been ignored." batch.js:2642:3852
"Your are trying to create a ToggleBlock with selector '.toggle-trigger'.One already exists with this trigger so has been ignored." batch.js:2642:3852
"Failed to run init function: TypeError: WRM.data.claim is not a function
function (d){var c=WRM.data.claim("com.atlassian.jira.ext.calendar:tipDataProvider.tip").suppressTip;if(!c){var a="browse-project-calendar-info";var b=function(e){if(e.length){var f=d("<div/>");AJS.messages.info(f,{body:AJS.format("This calendar shows when issues are due to be completed. This is set by the {0} field for an issue.","Due Date"),closeable:true});f.find(".aui-message").attr("id",a);e.prepend(f)}};JIRA.bind(JIRA.Events.NEW_CONTENT_ADDED,function(i,g,h){var f;if(g.attr("id")=="project-tab"){f=d(".issues-calendar-container",g)}else{f=d("#project-tab .issues-calendar-container",g)}b(f)});b(d("#project-tab .issues-calendar-container"));AJS.bind("messageClose",function(g,f){if(f.attr("id")==a){AJS.EventQueue&&AJS.EventQueue.push({name:"browseprojectcalendarinfo.closebutton"});d.ajax({data:{tipKey:"browseProjectCalendarTab"},type:"POST",url:contextPath+"/rest/calendar-plugin/1.0/suppressedTips"})}})}}" batch.js:195:344
"[behaviors] new content added, clearing outstanding errors..." batch.js:65:217
"TZDetect: Detected timezone as (GMT+02:00) Asia/Jerusalem, user prefs set to (GMT+00:00) Europe/London" batch.js:195:344
"Adding listeners: " batch.js:59:311
null batch.js:59:345
"------------------------------------- Loading package: Mail" zimbra:1552:0
"------------------------------------- Loading package: TinyMCE" zimbra:1552:0
"------------------------------------- Loading package: Tasks" zimbra:1552:0
"------------------------------------- Loading package: BriefcaseCore" zimbra:1552:0
"------------------------------------- Loading package: PreferencesCore, Preferences" zimbra:1552:0
"Tue Dec 22 14:45:10 GMT+200 2015 org.ovirt.engine.ui.common.uicommon.ContextSensitiveHelpManager
INFO: Context-sensitive help is installed on the server. The following locales are available: [en-US]" 06550BCB73EB7864DA79284790C1A9ED.cache.html:24013:12006
"Tue Dec 22 14:45:10 GMT+200 2015 org.ovirt.engine.ui.common.uicommon.ContextSensitiveHelpManager
INFO: Context-sensitive help for your locale, en-US, is installed and loaded." 06550BCB73EB7864DA79284790C1A9ED.cache.html:24013:12006
"Tue Dec 22 14:45:10 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Plugin [redhat_support_plugin_rhev] has registered the event handler object" 06550BCB73EB7864DA79284790C1A9ED.cache.html:24013:12006
"Tue Dec 22 14:45:10 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Plugin [redhat_support_plugin_rhev] reports in as ready" 06550BCB73EB7864DA79284790C1A9ED.cache.html:24013:12006
"Tue Dec 22 14:45:24 GMT+200 2015 org.ovirt.engine.ui.common.presenter.AbstractLoginPresenterWidget
WARNING: Login failed for user [vdcadmin]" 06550BCB73EB7864DA79284790C1A9ED.cache.html:24013:11964
"Tue Dec 22 14:45:38 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Initializing plugin [redhat_support_plugin_rhev]" 06550BCB73EB7864DA79284790C1A9ED.cache.html:24013:12006
"Tue Dec 22 14:45:38 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [UiInit] for plugin [redhat_support_plugin_rhev]" 06550BCB73EB7864DA79284790C1A9ED.cache.html:24013:12006
"Tue Dec 22 14:45:38 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Plugin [redhat_support_plugin_rhev] is initialized and in use now" 06550BCB73EB7864DA79284790C1A9ED.cache.html:24013:12006
"Tue Dec 22 14:45:38 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [RestApiSessionAcquired] for plugin [redhat_support_plugin_rhev]" 06550BCB73EB7864DA79284790C1A9ED.cache.html:24013:12006
"Tue Dec 22 14:45:38 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [UserLogin] for plugin [redhat_support_plugin_rhev]" 06550BCB73EB7864DA79284790C1A9ED.cache.html:24013:12006
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] GenericApiGWTService
"Tue Dec 22 14:46:56 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [SystemTreeSelectionChange] for plugin [redhat_support_plugin_rhev]" 06550BCB73EB7864DA79284790C1A9ED.cache.html:24013:12006
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] 9.cache.js
"Tue Dec 22 14:47:03 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev]" 06550BCB73EB7864DA79284790C1A9ED.cache.html:24013:12006
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] 61.cache.js
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] 68.cache.js
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] 63.cache.js
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] 64.cache.js
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] 65.cache.js
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] 66.cache.js
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] 67.cache.js
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] 69.cache.js
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] 70.cache.js
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] 71.cache.js
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] 72.cache.js
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] 73.cache.js
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] 74.cache.js
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] 75.cache.js
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] 62.cache.js
"Tue Dec 22 14:47:05 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev]" 06550BCB73EB7864DA79284790C1A9ED.cache.html:24013:12006
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] reports-interface-proxy
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] panel_edge_TR.png
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] panel_edge_T.png
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] panel_edge_TL.png
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] panel_edge_L.png
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] dialog_header_TL.png
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] dialog_header_background_repetitive.png
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] dialog_header_TR.png
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] dialog_header_TR_decoration.png
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] panel_edge_B.png
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] panel_edge_R.png
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] panel_edge_BR.png
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] panel_edge_BL.png
"Tue Dec 22 14:47:22 GMT+200 2015 
SEVERE: Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: Exception caught: (TypeError) 
 __gwt$exception: <skipped>: a is null
	at Unknown.ms(Unknown Source)
	at Unknown.us(Unknown Source)
	at Unknown.e3(Unknown Source)
	at Unknown.h3(Unknown Source)
	at Unknown.s2(Unknown Source)
	at Unknown.guf(Unknown Source)
	at Unknown.suf(Unknown Source)
	at Unknown.wuf(Unknown Source)
	at Unknown.LTe(Unknown Source)
	at Unknown.zSe(Unknown Source)
	at Unknown.$ay(Unknown Source)
	at Unknown.sby(Unknown Source)
	at Unknown.RHr(Unknown Source)
	at Unknown.bpo(Unknown Source)
	at Unknown.Wwo(Unknown Source)
	at Unknown.nxo(Unknown Source)
	at Unknown.PMn(Unknown Source)
	at Unknown.SMn(Unknown Source)
	at Unknown.JQn(Unknown Source)
	at Unknown.MQn(Unknown Source)
	at Unknown.BPn(Unknown Source)
	at Unknown.EPn(Unknown Source)
	at Unknown.DHe(Unknown Source)
	at Unknown.Lvk(Unknown Source)
	at Unknown.r3(Unknown Source)
	at Unknown.K3(Unknown Source)
	at Unknown.Fuf/c.onreadystatechange<(Unknown Source)
	at Unknown.Yt(Unknown Source)
	at Unknown.au(Unknown Source)
	at Unknown._t/<(Unknown Source)
	at Unknown.anonymous(Unknown Source)
Caused by: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) 
 __gwt$exception: <skipped>: a is null
	at Unknown.ms(Unknown Source)
	at Unknown.us(Unknown Source)
	at Unknown.e3(Unknown Source)
	at Unknown.h3(Unknown Source)
	at Unknown.l2(Unknown Source)
	at Unknown.$Fx(Unknown Source)
	at Unknown.CFx(Unknown Source)
	at Unknown.MFx(Unknown Source)
	at Unknown.fuf(Unknown Source)
	at Unknown.C2(Unknown Source)
	at Unknown.s2(Unknown Source)
	at Unknown.guf(Unknown Source)
	at Unknown.suf(Unknown Source)
	at Unknown.wuf(Unknown Source)
	at Unknown.LTe(Unknown Source)
	at Unknown.zSe(Unknown Source)
	at Unknown.$ay(Unknown Source)
	at Unknown.sby(Unknown Source)
	at Unknown.RHr(Unknown Source)
	at Unknown.bpo(Unknown Source)
	at Unknown.Wwo(Unknown Source)
	at Unknown.nxo(Unknown Source)
	at Unknown.PMn(Unknown Source)
	at Unknown.SMn(Unknown Source)
	at Unknown.JQn(Unknown Source)
	at Unknown.MQn(Unknown Source)
	at Unknown.BPn(Unknown Source)
	at Unknown.EPn(Unknown Source)
	at Unknown.DHe(Unknown Source)
	at Unknown.Lvk(Unknown Source)
	at Unknown.r3(Unknown Source)
	at Unknown.K3(Unknown Source)
	at Unknown.Fuf/c.onreadystatechange<(Unknown Source)
	at Unknown.Yt(Unknown Source)
	at Unknown.au(Unknown Source)
	at Unknown._t/<(Unknown Source)
	at Unknown.anonymous(Unknown Source)
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 __gwt$exception: <skipped>: a is null
	at Unknown.h7r(Unknown Source)
	at Unknown.WFx(Unknown Source)
	at Unknown.YFx(Unknown Source)
	at Unknown.C2(Unknown Source)
	at Unknown.l2(Unknown Source)
	at Unknown.$Fx(Unknown Source)
	at Unknown.CFx(Unknown Source)
	at Unknown.MFx(Unknown Source)
	at Unknown.fuf(Unknown Source)
	at Unknown.C2(Unknown Source)
	at Unknown.s2(Unknown Source)
	at Unknown.guf(Unknown Source)
	at Unknown.suf(Unknown Source)
	at Unknown.wuf(Unknown Source)
	at Unknown.LTe(Unknown Source)
	at Unknown.zSe(Unknown Source)
	at Unknown.$ay(Unknown Source)
	at Unknown.sby(Unknown Source)
	at Unknown.RHr(Unknown Source)
	at Unknown.bpo(Unknown Source)
	at Unknown.Wwo(Unknown Source)
	at Unknown.nxo(Unknown Source)
	at Unknown.PMn(Unknown Source)
	at Unknown.SMn(Unknown Source)
	at Unknown.JQn(Unknown Source)
	at Unknown.MQn(Unknown Source)
	at Unknown.BPn(Unknown Source)
	at Unknown.EPn(Unknown Source)
	at Unknown.DHe(Unknown Source)
	at Unknown.Lvk(Unknown Source)
	at Unknown.r3(Unknown Source)
	at Unknown.K3(Unknown Source)
	at Unknown.Fuf/c.onreadystatechange<(Unknown Source)
	at Unknown.Yt(Unknown Source)
	at Unknown.au(Unknown Source)
	at Unknown._t/<(Unknown Source)
	at Unknown.anonymous(Unknown Source)
" 06550BCB73EB7864DA79284790C1A9ED.cache.html:24013:11921

This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] api
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] NoOpRequest
"[CustomizeMode]" "Widget with id loop-button does not return a valid node" CustomizeMode.jsm:63
1450788568175	Sync.Tracker.Clients	WARN	Changed IDs file clients contains non-object value.
1450788568318	Sync.Tracker.Bookmarks	WARN	Changed IDs file bookmarks contains non-object value.
1450788568354	Sync.Tracker.Forms	WARN	Changed IDs file forms contains non-object value.
1450788568355	Sync.Tracker.History	WARN	Changed IDs file history contains non-object value.
1450788568356	Sync.Tracker.Passwords	WARN	Changed IDs file passwords contains non-object value.
1450788568358	Sync.Tracker.Addons	WARN	Changed IDs file addons contains non-object value.



-------------------------------------------------------------------------------










FROM A CROMIUM BROWSER
-------------------------------------------------------------------------------
Tue Dec 22 12:52:33 GMT+200 2015 org.ovirt.engine.ui.common.place.ApplicationPlaceManager
WARNING: Unauthorized place request - the user is not allowed to access 'hosts' FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 12:52:33 GMT+200 2015 org.ovirt.engine.ui.common.uicommon.ContextSensitiveHelpManager
INFO: Context-sensitive help is installed on the server. The following locales are available: [en-US] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 12:52:33 GMT+200 2015 org.ovirt.engine.ui.common.uicommon.ContextSensitiveHelpManager
INFO: Context-sensitive help for your locale, en-US, is installed and loaded. FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 12:52:33 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Plugin [redhat_support_plugin_rhev] has registered the event handler object FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 12:52:33 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Plugin [redhat_support_plugin_rhev] reports in as ready FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=webadmin-ui-xml
Tue Dec 22 12:52:45 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Initializing plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 12:52:45 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [UiInit] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 12:52:45 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Plugin [redhat_support_plugin_rhev] is initialized and in use now FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 12:52:45 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [RestApiSessionAcquired] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 12:52:45 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [UserLogin] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 12:52:55 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [SystemTreeSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 12:53:09 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Tue Dec 22 12:55:33 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 12:55:38 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Tue Dec 22 12:55:55 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 12:55:56 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Failed to load resource: the server responded with a status of 404 (Not Found) https://10.35.161.30/ovirt-engine/services/reports-interface-proxy?command=status
Tue Dec 22 13:51:11 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 13:57:24 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 14:00:44 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 14:00:48 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 14:00:49 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 14:00:57 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 14:01:00 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 14:01:09 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 14:01:10 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 14:01:31 GMT+200 2015 
SEVERE: Uncaught exception: com.google.gwt.event.shared.UmbrellaException: Exception caught: Exception caught: (TypeError) 
 stack: TypeError: Cannot read property 'f' of null
    at L7r (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:18426:41)
    at yGx (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:18469:74)
    at Object.AGx [as zf] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24184:6440)
    at W2 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:22873:209)
    at F2 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:19301:28)
    at CGx (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:14613:44)
    at eGx (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:18991:83)
    at Object.oGx [as uj] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24184:6190)
    at Object.Euf [as zf] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24019:11903)
    at W2 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:22873:209)
    at M2 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:21386:59)
    at Fuf (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:14168:41)
    at Ruf (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:20848:162)
    at Object.Vuf [as ml] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24019:12208)
    at hUe (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:23927:1172)
    at XSe (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:16208:33)
    at Cby (<anonymous>:193:53)
    at Object.Wby [as g6] (<anonymous>:270:18564)
    at tIr (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:21562:189)
    at Fpo (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:23370:309)
    at yxo (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:23928:2599)
    at Object.Rxo (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24097:8260)
    at rNn (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:20359:116)
    at Object.uNn [as h7] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24091:568)
    at lRn (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:18898:74)
    at Object.oRn [as h7] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24091:25763)
    at dQn (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:21907:180)
    at Object.gQn [as Aj] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24091:24407)
    at Object.cIe [as lg] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013:18964)
    at Object.nwk [as lg] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24055:8016)
    at L3 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:20306:137)
    at Object.c4 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013:6679)
    at XMLHttpRequest.<anonymous> (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:16861:65)
    at _t (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:12059:29)
    at du (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:21173:57)
    at XMLHttpRequest.<anonymous> (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:20538:54)
 __gwt$exception: <skipped>: Cannot read property 'f' of null
	at Unknown.ps(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@2346)
	at Unknown.xs(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@41)
	at Unknown.y3(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@19)
	at Unknown.B3(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@19)
	at Unknown.M2(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@117)
	at Unknown.Fuf(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@41)
	at Unknown.Ruf(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@162)
	at Unknown.Vuf(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@12208)
	at Unknown.hUe(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@1172)
	at Unknown.XSe(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@33)
	at Unknown.Cby(<anonymous>@53)
	at Unknown.Wby(<anonymous>@18564)
	at Unknown.tIr(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@189)
	at Unknown.Fpo(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@309)
	at Unknown.yxo(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@2599)
	at Unknown.Rxo(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@8260)
	at Unknown.rNn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@116)
	at Unknown.uNn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@568)
	at Unknown.lRn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@74)
	at Unknown.oRn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@25763)
	at Unknown.dQn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@180)
	at Unknown.gQn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@24407)
	at Unknown.cIe(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@18964)
	at Unknown.nwk(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@8016)
	at Unknown.L3(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@137)
	at Unknown.c4(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@6679)
	at Unknown.<anonymous>(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@65)
	at Unknown._t(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@29)
	at Unknown.du(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@57)
	at Unknown.<anonymous>(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@54)
Caused by: com.google.gwt.event.shared.UmbrellaException: Exception caught: (TypeError) 
 stack: TypeError: Cannot read property 'f' of null
    at L7r (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:18426:41)
    at yGx (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:18469:74)
    at Object.AGx [as zf] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24184:6440)
    at W2 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:22873:209)
    at F2 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:19301:28)
    at CGx (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:14613:44)
    at eGx (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:18991:83)
    at Object.oGx [as uj] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24184:6190)
    at Object.Euf [as zf] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24019:11903)
    at W2 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:22873:209)
    at M2 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:21386:59)
    at Fuf (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:14168:41)
    at Ruf (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:20848:162)
    at Object.Vuf [as ml] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24019:12208)
    at hUe (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:23927:1172)
    at XSe (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:16208:33)
    at Cby (<anonymous>:193:53)
    at Object.Wby [as g6] (<anonymous>:270:18564)
    at tIr (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:21562:189)
    at Fpo (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:23370:309)
    at yxo (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:23928:2599)
    at Object.Rxo (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24097:8260)
    at rNn (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:20359:116)
    at Object.uNn [as h7] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24091:568)
    at lRn (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:18898:74)
    at Object.oRn [as h7] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24091:25763)
    at dQn (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:21907:180)
    at Object.gQn [as Aj] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24091:24407)
    at Object.cIe [as lg] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013:18964)
    at Object.nwk [as lg] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24055:8016)
    at L3 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:20306:137)
    at Object.c4 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013:6679)
    at XMLHttpRequest.<anonymous> (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:16861:65)
    at _t (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:12059:29)
    at du (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:21173:57)
    at XMLHttpRequest.<anonymous> (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:20538:54)
 __gwt$exception: <skipped>: Cannot read property 'f' of null
	at Unknown.ps(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@2346)
	at Unknown.xs(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@41)
	at Unknown.y3(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@19)
	at Unknown.B3(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@19)
	at Unknown.F2(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@86)
	at Unknown.CGx(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@44)
	at Unknown.eGx(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@83)
	at Unknown.oGx(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@6190)
	at Unknown.Euf(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@11903)
	at Unknown.W2(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@209)
	at Unknown.M2(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@59)
	at Unknown.Fuf(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@41)
	at Unknown.Ruf(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@162)
	at Unknown.Vuf(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@12208)
	at Unknown.hUe(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@1172)
	at Unknown.XSe(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@33)
	at Unknown.Cby(<anonymous>@53)
	at Unknown.Wby(<anonymous>@18564)
	at Unknown.tIr(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@189)
	at Unknown.Fpo(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@309)
	at Unknown.yxo(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@2599)
	at Unknown.Rxo(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@8260)
	at Unknown.rNn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@116)
	at Unknown.uNn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@568)
	at Unknown.lRn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@74)
	at Unknown.oRn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@25763)
	at Unknown.dQn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@180)
	at Unknown.gQn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@24407)
	at Unknown.cIe(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@18964)
	at Unknown.nwk(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@8016)
	at Unknown.L3(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@137)
	at Unknown.c4(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@6679)
	at Unknown.<anonymous>(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@65)
	at Unknown._t(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@29)
	at Unknown.du(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@57)
	at Unknown.<anonymous>(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@54)
Caused by: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 stack: TypeError: Cannot read property 'f' of null
    at L7r (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:18426:41)
    at yGx (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:18469:74)
    at Object.AGx [as zf] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24184:6440)
    at W2 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:22873:209)
    at F2 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:19301:28)
    at CGx (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:14613:44)
    at eGx (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:18991:83)
    at Object.oGx [as uj] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24184:6190)
    at Object.Euf [as zf] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24019:11903)
    at W2 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:22873:209)
    at M2 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:21386:59)
    at Fuf (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:14168:41)
    at Ruf (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:20848:162)
    at Object.Vuf [as ml] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24019:12208)
    at hUe (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:23927:1172)
    at XSe (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:16208:33)
    at Cby (<anonymous>:193:53)
    at Object.Wby [as g6] (<anonymous>:270:18564)
    at tIr (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:21562:189)
    at Fpo (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:23370:309)
    at yxo (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:23928:2599)
    at Object.Rxo (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24097:8260)
    at rNn (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:20359:116)
    at Object.uNn [as h7] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24091:568)
    at lRn (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:18898:74)
    at Object.oRn [as h7] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24091:25763)
    at dQn (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:21907:180)
    at Object.gQn [as Aj] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24091:24407)
    at Object.cIe [as lg] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013:18964)
    at Object.nwk [as lg] (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24055:8016)
    at L3 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:20306:137)
    at Object.c4 (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013:6679)
    at XMLHttpRequest.<anonymous> (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:16861:65)
    at _t (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:12059:29)
    at du (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:21173:57)
    at XMLHttpRequest.<anonymous> (https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html:20538:54)
 __gwt$exception: <skipped>: Cannot read property 'f' of null
	at Unknown.L7r(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@41)
	at Unknown.yGx(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@74)
	at Unknown.AGx(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@6440)
	at Unknown.W2(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@209)
	at Unknown.F2(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@28)
	at Unknown.CGx(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@44)
	at Unknown.eGx(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@83)
	at Unknown.oGx(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@6190)
	at Unknown.Euf(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@11903)
	at Unknown.W2(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@209)
	at Unknown.M2(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@59)
	at Unknown.Fuf(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@41)
	at Unknown.Ruf(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@162)
	at Unknown.Vuf(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@12208)
	at Unknown.hUe(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@1172)
	at Unknown.XSe(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@33)
	at Unknown.Cby(<anonymous>@53)
	at Unknown.Wby(<anonymous>@18564)
	at Unknown.tIr(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@189)
	at Unknown.Fpo(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@309)
	at Unknown.yxo(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@2599)
	at Unknown.Rxo(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@8260)
	at Unknown.rNn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@116)
	at Unknown.uNn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@568)
	at Unknown.lRn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@74)
	at Unknown.oRn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@25763)
	at Unknown.dQn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@180)
	at Unknown.gQn(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@24407)
	at Unknown.cIe(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@18964)
	at Unknown.nwk(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@8016)
	at Unknown.L3(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@137)
	at Unknown.c4(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@6679)
	at Unknown.<anonymous>(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@65)
	at Unknown._t(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@29)
	at Unknown.du(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@57)
	at Unknown.<anonymous>(https://10.35.161.30/ovirt-engine/webadmin/FDE3173EFA54285317FD6DF1971D93DC.cache.html@54)
 FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 14:06:11 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 14:06:13 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 14:06:15 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 14:06:18 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Tue Dec 22 14:06:20 GMT+200 2015 org.ovirt.engine.ui.webadmin.plugin.PluginManager
INFO: Invoking event handler function [HostSelectionChange] for plugin [redhat_support_plugin_rhev] FDE3173EFA54285317FD6DF1971D93DC.cache.html:24013
Comment 1 Kevin Alon Goldblatt 2015-12-22 08:39 EST
Created attachment 1108640 [details]
engine, vdsm, server logs

Added logs
Comment 2 Oved Ourfali 2015-12-23 07:52:01 EST
(In reply to Kevin Alon Goldblatt from comment #0)
> Description of problem:
> On a system with compatibility version 3.5 on the DC and Cluster, with
> engines and hosts with 3.6.1.7. When moving my hosts into maintenance mode
> and exception occurs
> 
> Version-Release number of selected component (if applicable):
> rhevm-3.6.1.3-0.1.el6.noarch
> vdsm-4.17.13-1.el7ev.noarch
> 
> 
> How reproducible:
> Reproduced this on 4 attempts on different hosts and different browsers
> 
> 
> Steps to Reproduce:
> 1. DC and Cluster compatibility version 3.5
> 2. Via the Webadmin -> Select DC in the tree -> select a host - currently
> installed with 3.5 and move it to maintenance mode >>>>> The exception below
> is generated
> 
> Actual results:
> An exception is generated when moving the host into maintenance mode

All I see in the engine log is that migration failed (of "vm1", and that's why the host wasn't moved to maintenance).

Can you re-test on a host without running VMs?
Can you re-test on a host with running VMs and check whether it is moved correctly?

Alexander, any clue why he sees such UI exception?
Comment 3 Alexander Wels 2015-12-23 09:25:32 EST
Well most likely due to the fact that putting the host in maintaince failed, something in the UI didn't like that and caused the exception. Looks like some object that normally is populated from the back-end ended up as a null and we are trying to read a field value.

There are some steps we can take to debug more in depth exactly where the null value happened. But it is a little involved. Before we didn't capture and display any exceptions that weren't handled, they just disappeared onto the console that no-one ever looked at.

Since this is like the 4th or 5th different instance where we have the need to debug more in depth, I am going to create a wiki page that explains the steps. Once I am done, I will link it here.
Comment 4 Oved Ourfali 2015-12-23 09:29:51 EST
Restoring needinfo on Kevin.
Comment 5 Alexander Wels 2015-12-23 12:05:02 EST
The link on how to debug this [1]

@Kevin,
Can you follow the steps outline in the link and give me result of step 4 in that link here. That will help me tremendously in figuring out the cause of the exception popup.

Alexander

[1] http://www.ovirt.org/OVirt_Engine_Debug_Obfuscated_UI
Comment 6 Kevin Alon Goldblatt 2015-12-30 05:15:39 EST
(In reply to Alexander Wels from comment #5)
> The link on how to debug this [1]
> 
> @Kevin,
> Can you follow the steps outline in the link and give me result of step 4 in
> that link here. That will help me tremendously in figuring out the cause of
> the exception popup.
> 
> Alexander
> 
> [1] http://www.ovirt.org/OVirt_Engine_Debug_Obfuscated_UI

Hi,

I followed the steps in the link above, however the debug info packages you indicated to install do not exist for Ovirt 3.6.1 or 3.6.2. I could only find them for 3.5. Please could you provide the debug packages /url so I can install them.
Comment 7 Oved Ourfali 2015-12-30 06:02:19 EST
Kevin, also see my questions from comment #2.
Comment 8 Oved Ourfali 2015-12-30 06:40:35 EST
(In reply to Kevin Alon Goldblatt from comment #6)
> (In reply to Alexander Wels from comment #5)
> > The link on how to debug this [1]
> > 
> > @Kevin,
> > Can you follow the steps outline in the link and give me result of step 4 in
> > that link here. That will help me tremendously in figuring out the cause of
> > the exception popup.
> > 
> > Alexander
> > 
> > [1] http://www.ovirt.org/OVirt_Engine_Debug_Obfuscated_UI
> 
> Hi,
> 
> I followed the steps in the link above, however the debug info packages you
> indicated to install do not exist for Ovirt 3.6.1 or 3.6.2. I could only
> find them for 3.5. Please could you provide the debug packages /url so I can
> install them.

I think those can be found in 
http://resources.ovirt.org/pub/ovirt-3.6-pre/rpm/el6.7/noarch/

(well, depending on the right version you have you might need to go to:
http://resources.ovirt.org/pub/ovirt-3.6-snapshot/
or another).

Leaving needinfo on Alexander, just in case I'm wrong.
But, my questions should be answered regardless of the UI debugging.

Note You need to log in before you can comment on or make changes to this bug.