Bug 1293660 - Uninstall of local load-balancer always fails
Uninstall of local load-balancer always fails
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Andrew Butcher
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 10:40 EST by Robert Rati
Modified: 2016-07-03 20:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 14:43:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2015-12-22 10:40:55 EST
Description of problem:
I installed a 3 master, 3 etcd ha setup with a local load-balancer (ie with [lb] section).  When running through the uninstall, all nodes uninstall successfully except the load-balancer.

Version-Release number of selected component (if applicable):
openshift-ansible-playbooks-3.0.13-1.git.0.5e8c5c7.el7aos.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install 3 master, 3 etcd with local load-balancer
2. Uninstall via /usr/share/ansible/openshift-ansible/playbooks/adhoc/uninstall.yml
3.

Actual results:
All nodes uninstall w/o error except the load-balancer

Expected results:
All nodes including the load-balancer uninstall successfully.

Additional info:
Comment 3 Ma xiaoqiang 2016-01-06 03:18:49 EST
Check against openshift-ansible-3.0.21-1.git.6.d562263.el7aos.noarch

When uninstalling env:
TASK: [Stop services] ********************************************************* 
<--snip-->
ok: [openshift-138.lab.eng.nay.redhat.com] => (item=haproxy)
<--snip-->
TASK: [Remove packages] ******************************************************* 
<--snip-->
changed: [openshift-147.lab.eng.nay.redhat.com] => (item=haproxy)

Move this issue to VERIFIED.
Comment 5 errata-xmlrpc 2016-01-27 14:43:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0075

Note You need to log in before you can comment on or make changes to this bug.