Bug 1293701 - iio-sensor-proxy lenovo yoga 3 900
iio-sensor-proxy lenovo yoga 3 900
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: iio-sensor-proxy (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
:
: 1364831 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 13:24 EST by Yogesh Sharma
Modified: 2016-08-08 07:52 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-28 09:38:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yogesh Sharma 2015-12-22 13:24:56 EST
Screen rotation not working on fedora.
Fedoa 23 + Kernel from rawhide 4.4.0-0.rc5.git3.1.fc24.x86_64

gdbus introspect --system --dest net.hadess.SensorProxy --object-path /net/hadess/SensorProxy
node /net/hadess/SensorProxy {
  interface org.freedesktop.DBus.Properties {
    methods:
      Get(in  s interface_name,
          in  s property_name,
          out v value);
      GetAll(in  s interface_name,
             out a{sv} properties);
      Set(in  s interface_name,
          in  s property_name,
          in  v value);
    signals:
      PropertiesChanged(s interface_name,
                        a{sv} changed_properties,
                        as invalidated_properties);
    properties:
  };
  interface org.freedesktop.DBus.Introspectable {
    methods:
      Introspect(out s xml_data);
    signals:
    properties:
  };
  interface org.freedesktop.DBus.Peer {
    methods:
      Ping();
      GetMachineId(out s machine_uuid);
    signals:
    properties:
  };
  interface net.hadess.SensorProxy {
    methods:
      ClaimAccelerometer();
      ReleaseAccelerometer();
      ClaimLight();
      ReleaseLight();
    signals:
    properties:
      readonly b HasAccelerometer = true;
      readonly s AccelerometerOrientation = 'undefined';
      readonly b HasAmbientLight = true;
      readonly s LightLevelUnit = 'lux';
      readonly d LightLevel = 0.0;
  };
  node Compass {
  };
};
Comment 1 Igor Gnatenko 2016-06-28 09:38:16 EDT
Let's track it in upstream.
Comment 2 Igor Gnatenko 2016-08-08 07:44:14 EDT
*** Bug 1364831 has been marked as a duplicate of this bug. ***
Comment 3 Steven D. 2016-08-08 07:52:45 EDT
Do you have a link to the upstream bug report? I can't seem to find it.

Note You need to log in before you can comment on or make changes to this bug.