Bug 1293715 - gr-osmosdr requires boost 1.54.0 Fedora 23 has 1.58.0 [NEEDINFO]
gr-osmosdr requires boost 1.54.0 Fedora 23 has 1.58.0
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gr-osmosdr (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 14:40 EST by Morris Jones
Modified: 2016-05-25 11:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-25 11:36:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jskarvad: needinfo? (mojoteri)


Attachments (Terms of Use)

  None (edit)
Description Morris Jones 2015-12-22 14:40:11 EST
Description of problem:
the gr-osmosdr swig requires boost 1.54.0 libraries. Fedora has 1.58.0 available.
This prevents running in GNUradio


Version-Release number of selected component (if applicable):
gr-osmosdr.x86_64                       0.1.3-12.20141023git42c66fdd.fc23


How reproducible:
Always


Steps to Reproduce:
1. install gnuradio and gr-osmosdr
2. use osmosdr source in a model
3. Attempt to run the model

Actual results:
Fails needing a boost library 1.54.0
File "/usr/lib64/python2.7/site-packages/osmosdr/osmosdr_swig.py", line 24, in swig_import_helper
    _mod = imp.load_module('_osmosdr_swig', fp, pathname, description)
ImportError: libboost_date_time.so.1.54.0: cannot open shared object file: No such file or directory

Expected results:
Receive a FM radio station

Additional info:
I tried linking the 1.58.0 to 1.54.0, but then there were undefined symbols during the link...
Comment 1 Jaroslav Škarvada 2016-01-04 06:02:11 EST
Is it still an issue? I am unable to reproduce with osmocom file source:

...
dlopen("/usr/lib64/python2.7/site-packages/osmosdr/_osmosdr_swig.so", 2);
linux; GNU C++ version 5.1.1 20150618 (Red Hat 5.1.1-4); Boost_105800; UHD_003.008.002-0-unknown
...

$ ldd /usr/lib64/python2.7/site-packages/osmosdr/_osmosdr_swig.so | grep boost
	libboost_thread.so.1.58.0 => /lib64/libboost_thread.so.1.58.0 (0x00007f9cdfc70000)
	libboost_system.so.1.58.0 => /lib64/libboost_system.so.1.58.0 (0x00007f9cdfa6c000)
	libboost_date_time.so.1.58.0 => /lib64/libboost_date_time.so.1.58.0 (0x00007f9cdc25a000)
	libboost_program_options.so.1.58.0 => /lib64/libboost_program_options.so.1.58.0 (0x00007f9cdbfe2000)
	libboost_filesystem.so.1.58.0 => /lib64/libboost_filesystem.so.1.58.0 (0x00007f9cdbdcd000)
	libboost_regex.so.1.58.0 => /lib64/libboost_regex.so.1.58.0 (0x00007f9cdaac5000)
	libboost_unit_test_framework.so.1.58.0 => /lib64/libboost_unit_test_framework.so.1.58.0 (0x00007f9cda821000)
	libboost_serialization.so.1.58.0 => /lib64/libboost_serialization.so.1.58.0 (0x00007f9cda5bf000)

$ rpm -q gnuradio
gnuradio-3.7.8.1-1.fc23.x86_64

$ rpm -q gr-osmosdr
gr-osmosdr-0.1.3-12.20141023git42c66fdd.fc23.x86_64

$ rpm -q boost
boost-1.58.0-10.fc23.x86_64
Comment 2 Jaroslav Škarvada 2016-05-25 11:36:14 EDT
Closing as worksforme because I am unable to reproduce the problem. If the problem persists please let me know or reopen this bugzilla.

Note You need to log in before you can comment on or make changes to this bug.