Bug 1293724 - apiServerArguments and controllerArgument needs to be able to be defined in ansible hosts file
apiServerArguments and controllerArgument needs to be able to be defined in a...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Jason DeTiberus
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 15:50 EST by Ryan Howe
Modified: 2016-07-03 20:46 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 12:37:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2015-12-22 15:50:17 EST
Description of problem:

apiServerArguments needs to be able to be defined in ansible hosts file

https://docs.openshift.com/enterprise/3.1/install_config/configuring_aws.html


Version-Release number of selected component (if applicable):
3.1

Additional info:

This may be possible already and may need to just be a docs bug. 

https://github.com/openshift/openshift-ansible/blob/15aa17c6162c036f6b164f225d2a071c138af965/roles/openshift_master/templates/master.yaml.v1.j2#L84


osm_api_server_args={'cloud-provider': ['aws'].'cloud-config':['/etc/aws/aws.conf']}

osm_controller_args={'cloud-provider':['aws'].'cloud-config':['/etc/aws/aws.conf']}
Comment 2 Jason DeTiberus 2016-03-15 22:55:01 EDT
It is possible to set these values using osm_controller_args and osm_api_server_args.

There is basic usage in the example inventory files provided in openshift-ansible.
Comment 3 Gaoyun Pei 2016-03-18 02:20:40 EDT
Specify the two parameters in ansible inventory:
osm_api_server_args={'cloud-provider' : ['aws'], 'cloud-config' : ['/etc/aws/aws.conf']}
osm_controller_args={'cloud-provider' : ['aws'], 'cloud-config' : ['/etc/aws/aws.conf']}


After installation, check the master-config.yml
kubernetesMasterConfig:
  apiServerArguments:
    cloud-config:
    - /etc/aws/aws.conf
    cloud-provider:
    - aws
  controllerArguments:
    cloud-config:
    - /etc/aws/aws.conf
    cloud-provider:
    - aws
  ...
Comment 5 errata-xmlrpc 2016-05-12 12:37:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1065

Note You need to log in before you can comment on or make changes to this bug.