Bug 1293726 - rhel-osp-director: 8.0 - heat resources are stopped in "pcs status" output.
rhel-osp-director: 8.0 - heat resources are stopped in "pcs status" output.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Jiri Stransky
Alexander Chuzhoy
: TestOnly, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 16:06 EST by Alexander Chuzhoy
Modified: 2016-04-07 17:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:43:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs from one controller. (4.56 MB, application/x-gzip)
2015-12-22 16:11 EST, Alexander Chuzhoy
no flags Details
crm report from rhos 7.1 with the same issue (2.83 MB, application/x-bzip)
2016-01-13 22:38 EST, Alexander Chuzhoy
no flags Details

  None (edit)
Description Alexander Chuzhoy 2015-12-22 16:06:02 EST
rhel-osp-director: 8.0 - heat resources are stopped in "pcs status" output.

Environment:
python-heatclient-0.8.0-1.el7ost.noarch
openstack-heat-engine-5.0.0-1.el7ost.noarch
openstack-heat-common-5.0.0-1.el7ost.noarch
openstack-heat-api-cfn-5.0.0-1.el7ost.noarch
openstack-heat-api-cloudwatch-5.0.0-1.el7ost.noarch
openstack-heat-api-5.0.0-1.el7ost.noarch


Steps to reproduce:
1. Deploy HA overcloud (used Bare metal setup with network isolation).
2. Run  pcs status|grep -B2 -i stop


Result:
 Clone Set: openstack-heat-engine-clone [openstack-heat-engine]
     Started: [ overcloud-controller-0 overcloud-controller-2 ]
     Stopped: [ overcloud-controller-1 ]
--
 Clone Set: openstack-heat-api-clone [openstack-heat-api]
     Started: [ overcloud-controller-0 overcloud-controller-2 ]
     Stopped: [ overcloud-controller-1 ]
--
 Clone Set: openstack-heat-api-cloudwatch-clone [openstack-heat-api-cloudwatch]
     Started: [ overcloud-controller-0 overcloud-controller-2 ]
     Stopped: [ overcloud-controller-1 ]
--
 Clone Set: openstack-heat-api-cfn-clone [openstack-heat-api-cfn]
     Started: [ overcloud-controller-0 overcloud-controller-2 ]
     Stopped: [ overcloud-controller-1 ]


Expected result:
No stopped services.
Comment 2 Alexander Chuzhoy 2015-12-22 16:11 EST
Created attachment 1108707 [details]
logs from one controller.
Comment 3 Alexander Chuzhoy 2015-12-22 16:16:11 EST
Environment:
instack-undercloud-2.2.0-1.el7ost.noarch
Comment 4 Alexander Chuzhoy 2016-01-04 12:31:08 EST
The issue doesn't re-occur on every deployment.
Comment 5 chris alfonso 2016-01-04 12:32:42 EST
Sasha, please attach a crm report and we'll send it over to the HA team
Comment 6 Alexander Chuzhoy 2016-01-13 22:38 EST
Created attachment 1114646 [details]
crm report from rhos 7.1  with the same issue
Comment 8 Hugh Brock 2016-02-05 09:43:20 EST
Sasha can you retest this on the latest OSPd 8 puddle once we have one? We need a CRM report from the failure on that code base, if it is still recurring.
Comment 9 Alexander Chuzhoy 2016-02-23 12:23:02 EST
Verified:

Environment:
python-heatclient-0.8.0-1.el7ost.noarch
openstack-heat-api-cfn-5.0.1-1.el7ost.noarch
openstack-heat-templates-0-0.1.20151019.el7ost.noarch
openstack-tripleo-heat-templates-0.8.7-12.el7ost.noarch
openstack-heat-api-5.0.1-1.el7ost.noarch
openstack-heat-engine-5.0.1-1.el7ost.noarch
openstack-tripleo-heat-templates-kilo-0.8.7-12.el7ost.noarch
openstack-heat-api-cloudwatch-5.0.1-1.el7ost.noarch
openstack-heat-common-5.0.1-1.el7ost.noarch



Deployed HA overcloud with network isolation: no stopped pcs resources .
Comment 12 errata-xmlrpc 2016-04-07 17:43:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.