Bug 1293740 - Schema fields reverse the order when added
Schema fields reverse the order when added
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity low
: GA
: 5.5.2
Assigned To: mkanoor
Ramesh A
: ZStream
Depends On: 1292791
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 16:58 EST by Chris Pelland
Modified: 2016-02-10 10:30 EST (History)
9 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1292791
Environment:
Last Closed: 2016-02-10 10:30:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 CFME Bot 2015-12-23 11:31:28 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=02bd4b2b0bffca222d7305a9d97cfac84944e9a4

commit 02bd4b2b0bffca222d7305a9d97cfac84944e9a4
Merge: ccfe61e d1715b8
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Wed Dec 23 11:27:53 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Wed Dec 23 11:27:53 2015 -0500

    Merge branch 'bugzilla_1293740' into '5.5.z'
    
    Priority wasn't being set for new fields
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1293740
    
    The priority wasn't being set for the newly added fields, before
    being saved the fields were sorted and the fields with nil priority
    floated to the top. Set the fields to the highest priority if they
    are new
    
    Clean Cherry Pick from PR https://github.com/ManageIQ/manageiq/pull/5950
    
    See merge request !664

 app/controllers/miq_ae_class_controller.rb       |  4 ++-
 spec/controllers/miq_ae_class_controller_spec.rb | 31 ++++++++++++++++++++++++
 2 files changed, 34 insertions(+), 1 deletion(-)
Comment 3 Ramesh A 2016-01-18 11:12:40 EST
Good to go. Verified and working fine in 5.5.2.1.20160114044944_395c086
Comment 4 errata-xmlrpc 2016-02-10 10:30:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.