Bug 1293741 - Tenant automation domains - undefined method `first' for nil:NilClass [miq_ae_class/x_button]
Tenant automation domains - undefined method `first' for nil:NilClass [miq_ae...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity unspecified
: GA
: 5.5.2
Assigned To: Harpreet Kataria
Pavol Kotvan
: ZStream
Depends On: 1288512
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 17:01 EST by Chris Pelland
Modified: 2016-02-10 10:30 EST (History)
9 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1288512
Environment:
Last Closed: 2016-02-10 10:30:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Harpreet Kataria 2016-01-05 14:19:04 EST
https://github.com/ManageIQ/manageiq/pull/6045
Comment 2 CFME Bot 2016-01-05 18:36:05 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/985b38455a2cce2fe1933a6bf6a2717fe8de5766

commit 985b38455a2cce2fe1933a6bf6a2717fe8de5766
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri Dec 18 13:53:06 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Tue Jan 5 15:20:30 2016 -0500

    Fixed button visibility of buttons in automate explorer.
    
    Added code to only make certain buttons visible when user's current tenant has any editable domains.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1288512
    https://bugzilla.redhat.com/show_bug.cgi?id=1293741

 app/helpers/application_helper/toolbar_builder.rb     |  2 +-
 app/models/tenant.rb                                  |  4 ++++
 .../application_helper/toolbar_builder_spec.rb        | 10 ++++++++++
 spec/models/tenant_spec.rb                            | 19 +++++++++++++++++++
 4 files changed, 34 insertions(+), 1 deletion(-)
Comment 4 CFME Bot 2016-01-06 11:42:31 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=edfb5602bb41c63c915b1b6ecdb130d795b8e1ff

commit edfb5602bb41c63c915b1b6ecdb130d795b8e1ff
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri Dec 18 13:53:06 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Jan 6 10:39:22 2016 -0500

    Fixed button visibility of buttons in automate explorer.
    
    Added code to only make certain buttons visible when user's current tenant has any editable domains.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1288512
    https://bugzilla.redhat.com/show_bug.cgi?id=1293741
    (cherry picked from commit 985b384)

 app/helpers/application_helper/toolbar_builder.rb     |  2 +-
 app/models/tenant.rb                                  |  4 ++++
 .../application_helper/toolbar_builder_spec.rb        | 10 ++++++++++
 spec/models/tenant_spec.rb                            | 19 +++++++++++++++++++
 4 files changed, 34 insertions(+), 1 deletion(-)
Comment 5 CFME Bot 2016-01-06 11:42:46 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=ed55df70e10f15f1a166f6688509e7993fc8a159

commit ed55df70e10f15f1a166f6688509e7993fc8a159
Merge: 00b549c edfb560
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Wed Jan 6 11:38:45 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Wed Jan 6 11:38:45 2016 -0500

    Merge branch '55z_pr_6045' into '5.5.z'
    
    Fixed button visibility of buttons in automate explorer.
    
    Added code to only make certain buttons visible when user's current tenant has any editable domains.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1288512
    https://bugzilla.redhat.com/show_bug.cgi?id=1293741
    (cherry picked from commit 985b384)
    
    @dclarizi please merge, clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/6045
    
    See merge request !677

 app/helpers/application_helper/toolbar_builder.rb     |  2 +-
 app/models/tenant.rb                                  |  4 ++++
 .../application_helper/toolbar_builder_spec.rb        | 10 ++++++++++
 spec/models/tenant_spec.rb                            | 19 +++++++++++++++++++
 4 files changed, 34 insertions(+), 1 deletion(-)
Comment 8 errata-xmlrpc 2016-02-10 10:30:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.