Bug 1293751 - [abrt] kpat: QXcbWindow::setParent(): kpat killed by SIGSEGV
[abrt] kpat: QXcbWindow::setParent(): kpat killed by SIGSEGV
Status: CLOSED DUPLICATE of bug 1291003
Product: Fedora
Classification: Fedora
Component: kpat (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:dae51f65deea5236faf83460271...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 19:57 EST by Joshua
Modified: 2016-01-01 23:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-01 23:32:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (40.24 KB, text/plain)
2015-12-22 19:57 EST, Joshua
no flags Details
File: cgroup (190 bytes, text/plain)
2015-12-22 19:57 EST, Joshua
no flags Details
File: core_backtrace (11.25 KB, text/plain)
2015-12-22 19:57 EST, Joshua
no flags Details
File: dso_list (15.63 KB, text/plain)
2015-12-22 19:57 EST, Joshua
no flags Details
File: environ (3.80 KB, text/plain)
2015-12-22 19:57 EST, Joshua
no flags Details
File: limits (1.29 KB, text/plain)
2015-12-22 19:57 EST, Joshua
no flags Details
File: maps (76.98 KB, text/plain)
2015-12-22 19:57 EST, Joshua
no flags Details
File: mountinfo (3.68 KB, text/plain)
2015-12-22 19:57 EST, Joshua
no flags Details
File: namespaces (85 bytes, text/plain)
2015-12-22 19:57 EST, Joshua
no flags Details
File: open_fds (1.28 KB, text/plain)
2015-12-22 19:57 EST, Joshua
no flags Details
File: proc_pid_status (1010 bytes, text/plain)
2015-12-22 19:57 EST, Joshua
no flags Details
File: var_log_messages (283 bytes, text/plain)
2015-12-22 19:57 EST, Joshua
no flags Details

  None (edit)
Description Joshua 2015-12-22 19:57:18 EST
Description of problem:
If I try to save a game it crashes

Version-Release number of selected component:
kpat-15.04.3-1.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        kpat
crash_function: QXcbWindow::setParent
executable:     /usr/bin/kpat
global_pid:     2038
kernel:         4.2.8-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 QXcbWindow::setParent at qxcbwindow.cpp:1499
 #1 QWindow::setParent at kernel/qwindow.cpp:614
 #2 QWidgetPrivate::setParent_sys at kernel/qwidget.cpp:10543
 #3 QWidget::setParent at kernel/qwidget.cpp:10398
 #5 QDialogButtonBox::addButton at widgets/qdialogbuttonbox.cpp:761
 #6 KDEPlatformFileDialog::KDEPlatformFileDialog at ../../../src/platformtheme/kdeplatformfiledialoghelper.cpp:103
 #7 KDEPlatformFileDialogHelper::KDEPlatformFileDialogHelper at ../../../src/platformtheme/kdeplatformfiledialoghelper.cpp:201
 #8 KdePlatformTheme::createPlatformDialogHelper at ../../../src/platformtheme/kdeplatformtheme.cpp:269
 #9 QDialogPrivate::platformHelper at dialogs/qdialog.cpp:94
 #10 QFileDialogPrivate::platformFileDialogHelper at dialogs/qfiledialog_p.h:112
Comment 1 Joshua 2015-12-22 19:57:23 EST
Created attachment 1108731 [details]
File: backtrace
Comment 2 Joshua 2015-12-22 19:57:24 EST
Created attachment 1108732 [details]
File: cgroup
Comment 3 Joshua 2015-12-22 19:57:25 EST
Created attachment 1108733 [details]
File: core_backtrace
Comment 4 Joshua 2015-12-22 19:57:26 EST
Created attachment 1108734 [details]
File: dso_list
Comment 5 Joshua 2015-12-22 19:57:27 EST
Created attachment 1108735 [details]
File: environ
Comment 6 Joshua 2015-12-22 19:57:28 EST
Created attachment 1108736 [details]
File: limits
Comment 7 Joshua 2015-12-22 19:57:29 EST
Created attachment 1108737 [details]
File: maps
Comment 8 Joshua 2015-12-22 19:57:30 EST
Created attachment 1108738 [details]
File: mountinfo
Comment 9 Joshua 2015-12-22 19:57:31 EST
Created attachment 1108739 [details]
File: namespaces
Comment 10 Joshua 2015-12-22 19:57:32 EST
Created attachment 1108740 [details]
File: open_fds
Comment 11 Joshua 2015-12-22 19:57:33 EST
Created attachment 1108741 [details]
File: proc_pid_status
Comment 12 Joshua 2015-12-22 19:57:33 EST
Created attachment 1108742 [details]
File: var_log_messages
Comment 13 Rex Dieter 2016-01-01 23:32:55 EST

*** This bug has been marked as a duplicate of bug 1291003 ***

Note You need to log in before you can comment on or make changes to this bug.