Bug 129377 - kernel-2.6.7-1.494.2.2 breaks ntfs
kernel-2.6.7-1.494.2.2 breaks ntfs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-07 03:38 EDT by David Lowe
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-09 07:45:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixed rpm build script (5.23 KB, text/plain)
2004-08-07 16:19 EDT, David Lowe
no flags Details

  None (edit)
Description David Lowe 2004-08-07 03:38:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
When I compile in support for the ntfs module, the module loads ok,
but a kernel oops is generated when I attempt to mount an ntfs
partition. This worked fine on all Fedora kernels up to
2.6.6-1.435.2.3, so the problem only appears on the new Fedora update
kernel.

I compiled the 2.6.8-rc3-mm1 kernel, and ntfs works fine



Version-Release number of selected component (if applicable):
kernel-2.6.7-1.494.2.2

How reproducible:
Always

Steps to Reproduce:
1. Compile ntfs support into kernel -- or use Flatcaps rpms
2. Load module, modprobe ntfs
3. mount /dev/hda2 /mnt/ntfs -t ntfs -r -o umask=0222
    

Actual Results:  Produces kernel oops, and mount fails

Expected Results:  mount successful

Additional info:

Here is one example of the kernel oops output:

NTFS driver 2.1.15 [Flags: R/O MODULE].
Unable to handle kernel paging request at virtual address 40000050
 printing eip:
2a8f279f
*pde = 00000000
Oops: 0000 [#1]
Modules linked in: nls_utf8 ntfs(U) vfat fat dm_mod uhci_hcd ext3 jbd
CPU:    0
EIP:    0060:[<2a8f279f>]    Not tainted
EFLAGS: 00010202   (2.6.7-1.494.2.2)
EIP is at ntfs_fill_super+0x11a/0x5c4 [ntfs]
eax: 40000000   ebx: 29f9b880   ecx: 02312ef6   edx: 00000092
esi: 00000000   edi: 29f9b940   ebp: 28ffdc00   esp: 28e9ee8c
ds: 007b   es: 007b   ss: 0068
Process mount (pid: 614, threadinfo=28e9e000 task=28a27930)
Stack: 0231181a 00000000 28c8e000 28c06834 28ffdc00 28c06800 00000000
02169087
       32616468 00000000 021431df 00000001 28a27930 00000010 00000000
000000d0
       02350600 00000000 29f7e880 2a8f9b20 2a8f2c68 28c8e000 2a8f2685
0216924c
Call Trace:
 [<02169087>] get_sb_bdev+0xdf/0x11b
 [<021431df>] __alloc_pages+0x2b4/0x2be
 [<2a8f2c68>] ntfs_get_sb+0xe/0x11 [ntfs]
 [<2a8f2685>] ntfs_fill_super+0x0/0x5c4 [ntfs]
 [<0216924c>] do_kern_mount+0x8a/0x13a
 [<021845d2>] do_new_mount+0x61/0x90
 [<021850ff>] do_mount+0x176/0x18e
 [<0215e37e>] get_user_size+0x2e/0x55
 [<021855dc>] sys_mount+0x121/0x1f9
Code: 8b 40 50 8b 40 34 85 c0 74 2b 0f b7 80 9e 01 00 00 66 85 c0
Comment 1 Arjan van de Ven 2004-08-07 03:40:33 EDT
how did you compile ntfs? The instructions on the ntfs sourceforge
page do not lead to a correct module!
Comment 2 David Lowe 2004-08-07 05:26:24 EDT
cd /usr/src/linux-2.6.7-1.494.2.2
make mrproper
cp configs/kernel-2.6.7-i686.config .config
echo "CONFIG_NTFS_FS=m" >> .config
Remove the custom tag from the Makefile
make oldconfig
make

However the build-2.6 script from the ntfs sourceforge page also
produced a module that inserted without error message (not sure if
thats what you meant by "a correct module").

Comment 3 Arjan van de Ven 2004-08-07 05:48:16 EDT
this is not the correct way to build a module, and in fact it will
generate an incorrect module!

You need to 
1) copy the fs/ntfs directory somewhere
2) Edit the makefile such that obj-$(CONFIG_NTFS_FS) += ntfs.o
  becomes obj-m += ntfs.o
3) make -C /lib/modules/`uname -r`/build SUBDIRS=$PWD modules


Comment 4 David Lowe 2004-08-07 06:23:12 EDT
Thanks, that works.
Comment 5 David Lowe 2004-08-07 16:19:18 EDT
Created attachment 102502 [details]
fixed rpm build script

It seems part of the problem was a nontrivial diff between the config files in
the kernel binaries and the sourcecode in the new update kernel, resulting in
the ntfs sourceforge script breaking. I have attached a modified version of the
script as per comment #3 to avoid such problems. Syntax is the same as on
http://linux-ntfs.sourceforge.net/rpm/build.html
but you need the kernel rpm, in addition to the kernel-sourcecode rpm.
Comment 6 Markus Huber 2004-08-07 23:28:32 EDT
Thank you David. The script works on a custom desktop and a HP zd7000
Notebook.
Markus

Note You need to log in before you can comment on or make changes to this bug.