Bug 1293792 - [RFE][HC]Ensure quorum and no running tasks before moving host to maintenance
[RFE][HC]Ensure quorum and no running tasks before moving host to maintenance
Status: CLOSED DUPLICATE of bug 1213291
Product: ovirt-engine
Classification: oVirt
Component: BLL.Gluster (Show other bugs)
Unspecified Unspecified
medium Severity medium (vote)
: ovirt-4.1.0-alpha
: ---
Assigned To: Ramesh N
: FutureFeature
Depends On:
Blocks: Generic_Hyper_Converged_Host Gluster-HC-2
  Show dependency treegraph
Reported: 2015-12-23 00:43 EST by Sahina Bose
Modified: 2016-11-02 07:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-11-02 07:48:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: Gluster
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sabose: ovirt‑4.1?
bmcclain: planning_ack+
sabose: devel_ack+
rule-engine: testing_ack?

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 43773 None None None 2016-10-26 08:32 EDT
oVirt gerrit 59102 None None None 2016-10-26 08:32 EDT

  None (edit)
Description Sahina Bose 2015-12-23 00:43:28 EST
Description of problem:

When moving a host to maintenance in a hyper-converged cluster, check that quorum is available. If quorum is not met, and host is moved to maintenance - the gluster volume will become read-only and VMs paused.

Also, if rebalance, remov-brick or self-heal is running, host should not be moved to maintenance

Version-Release number of selected component (if applicable):

How reproducible:

Additional info:
Users may need a way to override this warning and move host to maintenance.
Comment 1 Red Hat Bugzilla Rules Engine 2016-03-04 01:59:51 EST
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.
Comment 2 Sandro Bonazzola 2016-05-02 05:49:17 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 3 Yaniv Lavi 2016-05-23 09:13:40 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 4 Ramesh N 2016-11-02 07:48:25 EDT

*** This bug has been marked as a duplicate of bug 1213291 ***

Note You need to log in before you can comment on or make changes to this bug.