Bug 129380 - Focus Issue with new windows
Focus Issue with new windows
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-07 06:28 EDT by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-07 18:17:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2004-08-07 06:28:56 EDT
Description of problem:
metacity upgrade in rawhide introduced a few annoying focus related
behaviors with new windows.  The below behavior is different than FC1
and FC2.

Examples:
1) ALT-F2 pops up in front, but does not have focus automatically.
2) Click a link that launches a new browser window.  Window does not
pop in front, and it does not have focus.
3) Clicking on another program in the task manager more than once no
longer minimizes it again.

Version-Release number of selected component (if applicable):
metacity-2.8.2-1
Comment 1 Warren Togami 2004-08-07 06:39:21 EDT
4) Click on a different program in the task bar, and while it may
pop-up, it wont have focus.
Comment 2 Havoc Pennington 2004-08-07 18:17:11 EDT
http://bugzilla.gnome.org/show_bug.cgi?id=149028
Comment 3 Elijah Newren 2004-08-07 18:37:43 EDT
Actually, the reference for issue 4 is
http://bugzilla.gnome.org/show_bug.cgi?id=118372 (past comment 100 or
so; it really should have been a different bug--oops).  It the
_NET_ACTIVE_WINDOW isn't sent with a timestamp problem; it's both a
libwnck and metacity bug.

As for point 3, I saw that today but I thought I had only seen it with
my local patches.

Warren: What focus mode are you using (click, sloppy, focus), what
version of libwnck, and what other non-default options do you have set
for metacity (autoraise, etc.) if any?  100% reproducible?
Comment 4 Elijah Newren 2004-08-07 18:45:46 EDT
Oops, forgot to add myself to cc.  

Extra notes: Issue 1 is just part of the already-mentioned 'panel
isn't setting timestamps right' (failure to use startup-notification?)
in 149028.

I'm assuming issue 2 is only true so long as the browser is already
running, correct?  If not, there's an extra bug somewhere (due to not
using startup notification), and we need to know what app you're
clicking in to launch the browser.

But I'm most interested in issue 3; I wasn't aware of that one, so if
you could answer the above questions...
Comment 5 Elijah Newren 2004-08-07 18:57:24 EDT
Sorry for the spam.  One more question though, in regards to issue 3:
 When you clicked on the tasklist for the window the first time, was
the window correctly focused?  If not, maybe you just independently
discovered http://bugzilla.gnome.org/show_bug.cgi?id=149589.

Note You need to log in before you can comment on or make changes to this bug.