Bug 1293820 - [DOCS] Document how to use domain names in Endpoints
[DOCS] Document how to use domain names in Endpoints
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Gaurav Nelson
zhaozhanqi
Vikram Goyal
:
: 1342591 (view as bug list)
Depends On:
Blocks: 1267746
  Show dependency treegraph
 
Reported: 2015-12-23 02:27 EST by Alexander Koksharov
Modified: 2017-05-21 20:36 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-21 20:36:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Koksharov 2015-12-23 02:27:21 EST
Description of problem:
Problem with integrating external service into openshift. Requirement is to refer this service by domain name while Endpoind in openshift can be created by only providing ip address.

Version-Release number of selected component (if applicable):


How reproducible:
Example in step 2 of https://docs.openshift.com/enterprise/3.0/dev_guide/integrating_external_services.html#external-saas-provider looks like what is required.
{
  "kind": "Endpoints",
  "apiVersion": "v1",
  "metadata": {
    "name": "example-external-service" 
  },
  "subsets": [ 
    "api.mysaas.com:80",
    "api2.mysaas.com:8080"
  ]
}

System cant create such entity as it is against to a specification
https://docs.openshift.com/enterprise/3.0/rest_api/kubernetes_v1.html#v1-endpointsubset

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Josep 'Pep' Turro Mauri 2016-01-22 11:30:15 EST
Related upstream discussions:

https://github.com/kubernetes/kubernetes/pull/11838
https://github.com/kubernetes/kubernetes/issues/13748
Comment 4 Dan McPherson 2016-06-03 13:58:52 EDT
*** Bug 1342591 has been marked as a duplicate of this bug. ***
Comment 10 Josep 'Pep' Turro Mauri 2017-04-24 05:47:22 EDT
The ExternalName service type that covers this use case was released with OCP 3.5:

https://docs.openshift.com/container-platform/latest/release_notes/ocp_3_5_release_notes.html#ocp-35-ability-to-refer-to-external-endpoints-by-name

However, it seems there are no specific docs about it beyond that mention in the release notes, so I'm moving this to a documentation bug to address that.
Comment 11 Gaurav Nelson 2017-05-09 19:21:44 EDT
Created a pull request (https://github.com/openshift/openshift-docs/pull/4375) for adding this information in the relevant section.

Note You need to log in before you can comment on or make changes to this bug.