Bug 1293847 - (CVE-2015-8622, CVE-2015-8623, CVE-2015-8624, CVE-2015-8625, CVE-2015-8626, CVE-2015-8627, CVE-2015-8628) CVE-2015-8622 CVE-2015-8623 CVE-2015-8624 CVE-2015-8625 CVE-2015-8626 CVE-2015-8627 CVE-2015-8628 mediawiki: multiple flaws fixed in 1.26.1, 1.25.4, 1.24.5, and 1.23.12
CVE-2015-8622 CVE-2015-8623 CVE-2015-8624 CVE-2015-8625 CVE-2015-8626 CVE-201...
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20151221,repor...
: Security
Depends On: 1293849 1293848
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 04:30 EST by Martin Prpič
Modified: 2016-11-18 17:26 EST (History)
4 users (show)

See Also:
Fixed In Version: mediawiki 1.26.1, mediawiki 1.25.4, mediawiki 1.24.5, mediawiki 1.23.12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Prpič 2015-12-23 04:30:31 EST
Several flaws were found in Mediawiki:

* (T117899) XSS from wikitext when $wgArticlePath='$1'. Internal review
discovered an XSS vector when MediaWiki is configured with a non-standard
configuration.
<https://phabricator.wikimedia.org/T117899>

* (T119309) User::matchEditToken should use constant-time string
comparison. Internal review discovered that tokens were being compared as
strings, which could allow a timing attack. This should possibly have 2
CVE's assigned, one for the original patch to use hash_equals in
https://gerrit.wikimedia.org/r/#/c/156336/5/includes/User.php (released as
part of MediaWiki 1.25, and backported to 1.24 and 1.23 as part of this
patch) and one to fix T119309, related to the debugging statement.
<https://phabricator.wikimedia.org/T119309>

* (T118032) Error thrown by VirtualRESTService when POST variable starts
with '@'. Internal review discovered that MediaWiki was not sanitizing
parameters passed to the curl library, which could cause curl to upload
files from the webserver to an attacker.
<https://phabricator.wikimedia.org/T118032>

* (T115522) Passwords generated by User::randomPassword() may be shorter
than $wgMinimalPasswordLength. MediaWiki user Frank R. Farmer reported that
the password reset token could be shorter than the minimum required
password length.
<https://phabricator.wikimedia.org/T115522>

* (T97897) Incorrect parsing of IPs for global block. Wikimedia steward
Vituzzu reported that blocking IP addresses with zero-padded octets
resulted in a failure to block the IP address.
<https://phabricator.wikimedia.org/T97897>

* (T109724) A combination of Special:MyPage redirects and pagecounts allows
an external site to know the wikipedia login of an user. Wikimedia
user Xavier Combelle reported a way to identify user, when detailed page
view data is also released.
<https://phabricator.wikimedia.org/T109724>

CVE request and original report:

http://openwall.com/lists/oss-security/2015/12/21/8
Comment 1 Martin Prpič 2015-12-23 04:31:04 EST
Created mediawiki tracking bugs for this issue:

Affects: fedora-all [bug 1293848]
Affects: epel-all [bug 1293849]
Comment 2 Fedora Update System 2016-01-02 17:20:30 EST
mediawiki-1.26.2-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 3 Fedora Update System 2016-01-07 22:26:42 EST
mediawiki-1.26.2-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.