Bug 1293853 - Uncaught JS exception selecting unattached hosted_engine storage domain
Uncaught JS exception selecting unattached hosted_engine storage domain
Status: CLOSED DUPLICATE of bug 1290518
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.1.3
Unspecified Unspecified
high Severity urgent with 1 vote (vote)
: ovirt-3.6.2
: ---
Assigned To: bugs@ovirt.org
Pavel Stehlik
sla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 04:36 EST by Simone Tiraboschi
Modified: 2015-12-27 03:43 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-27 03:43:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dfediuck: ovirt‑3.6.z?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
Screenshot 1 (180.58 KB, image/png)
2015-12-23 04:36 EST, Simone Tiraboschi
no flags Details
Screenshot 2 (327.31 KB, image/png)
2015-12-23 04:37 EST, Simone Tiraboschi
no flags Details

  None (edit)
Description Simone Tiraboschi 2015-12-23 04:36:10 EST
Created attachment 1108874 [details]
Screenshot 1

Description of problem:

Since oVirt 3.6.1 the hosted-engine storage domain is visible in the engine but it's still not active due to another bug.

As I select it in the webadmin portal, I start getting Uncaught JS exception (see screenshot 1). Than I got an execption every a few seconds (see screenshot 2).

From the browser console the exception is:
Wed Dec 23 10:05:15 GMT+100 2015 
SEVERE: Uncaught exception: com.google.gwt.core.client.JavaScriptException: (TypeError) 
 __gwt$exception: <skipped>: Cannot read property 'k' of null
	at Unknown.twq(https://192.168.1.207/ovirt-engine/webadmin/407923C7C0980987EE42F541B756E846.cache.html@688)
	at Unknown.lNn(https://192.168.1.207/ovirt-engine/webadmin/407923C7C0980987EE42F541B756E846.cache.html@49)
	at Unknown.oNn(https://192.168.1.207/ovirt-engine/webadmin/407923C7C0980987EE42F541B756E846.cache.html@438)
	at Unknown.fRn(https://192.168.1.207/ovirt-engine/webadmin/407923C7C0980987EE42F541B756E846.cache.html@40)
	at Unknown.iRn(https://192.168.1.207/ovirt-engine/webadmin/407923C7C0980987EE42F541B756E846.cache.html@25647)
	at Unknown.NPn(https://192.168.1.207/ovirt-engine/webadmin/407923C7C0980987EE42F541B756E846.cache.html@25)
	at Unknown.QPn(https://192.168.1.207/ovirt-engine/webadmin/407923C7C0980987EE42F541B756E846.cache.html@23872)
	at Unknown.cIe(https://192.168.1.207/ovirt-engine/webadmin/407923C7C0980987EE42F541B756E846.cache.html@18964)
	at Unknown.nwk(https://192.168.1.207/ovirt-engine/webadmin/407923C7C0980987EE42F541B756E846.cache.html@8016)
	at Unknown.L3(https://192.168.1.207/ovirt-engine/webadmin/407923C7C0980987EE42F541B756E846.cache.html@137)
	at Unknown.c4(https://192.168.1.207/ovirt-engine/webadmin/407923C7C0980987EE42F541B756E846.cache.html@6679)
	at Unknown.<anonymous>(https://192.168.1.207/ovirt-engine/webadmin/407923C7C0980987EE42F541B756E846.cache.html@65)
	at Unknown._t(https://192.168.1.207/ovirt-engine/webadmin/407923C7C0980987EE42F541B756E846.cache.html@29)
	at Unknown.du(https://192.168.1.207/ovirt-engine/webadmin/407923C7C0980987EE42F541B756E846.cache.html@57)
	at Unknown.<anonymous>(https://192.168.1.207/ovirt-engine/webadmin/407923C7C0980987EE42F541B756E846.cache.html@54)


Prior events:
I deployed hosted-engine from 3.6.0 and I upgraded it to 3.6.1.

As for this one:
https://bugzilla.redhat.com/show_bug.cgi?id=1290518
hosted-engine storage domain is here but it's not active.

As for this one:
https://bugzilla.redhat.com/show_bug.cgi?id=1293338
ovirt-engine-extension-aaa-jdbc requires another run of engine-setup

but as for this one:
https://bugzilla.redhat.com/show_bug.cgi?id=1293689
some leftovers were in business_entity_snapshot table and I had to manually cleanup before being able to execute engine-setup again.


Version-Release number of selected component (if applicable):
ovirt-engine.noarch                        3.6.1.3-1.el7.centos       @ovirt-3.6

How reproducible:
Not sure, it has been reported also by another user on the user mailing list.

Steps to Reproduce:
1. deploy hosted-engine from 3.6.0 on NFS 
2. upgrade to 3.6.1


Actual results:
The NFS hosted-engine storage domain is in the engine but it's not active.
When I select it I got an uncaught JS exception from the webadmin portal.

Expected results:
I can successfully select the hosted-engine storage domain.

Additional info:
Comment 1 Simone Tiraboschi 2015-12-23 04:37 EST
Created attachment 1108875 [details]
Screenshot 2
Comment 2 Gianluca Cecchi 2015-12-23 07:16:30 EST
I confirm what detailed by Simone.
If it can be of any help I also updated the originale 3.6.0 system from CentOS 7.1 to CentOS 7.2, after updating engne to 3.6.1.
I don't know if in Simone's tests the base system has been left in 7.1 or not.
Comment 3 Roy Golan 2015-12-23 07:28:56 EST
Its a side effect of the Bug 1290518

In the bug above the domain is inserted but the StorageServerConnection details from the DB are missing. So the storage domain object is not complete and there is a an NPE that the GWT raises.
Comment 4 Roy Golan 2015-12-23 07:29:49 EST
(In reply to Gianluca Cecchi from comment #2)
> I confirm what detailed by Simone.
> If it can be of any help I also updated the originale 3.6.0 system from
> CentOS 7.1 to CentOS 7.2, after updating engne to 3.6.1.
> I don't know if in Simone's tests the base system has been left in 7.1 or
> not.

So you can't activate your hosted engine domain at that point?
Comment 5 Roy Golan 2015-12-23 07:30:18 EST
So you can't activate your hosted engine domain at that point?
Comment 6 Simone Tiraboschi 2015-12-23 07:33:32 EST
Roy, I cannot.
Comment 7 Einav Cohen 2015-12-23 07:50:10 EST
(In reply to Roy Golan from comment #3)
> Its a side effect of the Bug 1290518
> 

based on that, marking as 'sla' (maybe make sense to close on duplicate, not sure). 
please contact awels if you need assistance specifically with javascript-exception investigation.
Comment 8 Matthew Trent 2015-12-23 12:25:01 EST
I had this same issue upgrading from 3.5.x to 3.6.1. "hosted_storage" was there, but not active. Clicking the hosted_storage domain on the Storage tab came up with the JS exception, plus the "path:" field was absent from the General pane.

I was able to resolve by detaching "hosted_storage", then using "Attach Data" on the Data Centers tab to add it again.
Comment 9 Doron Fediuck 2015-12-27 03:43:14 EST

*** This bug has been marked as a duplicate of bug 1290518 ***

Note You need to log in before you can comment on or make changes to this bug.